summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-30 19:46:29 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-30 19:46:29 -0400
commitdcf13f76bb21a31516de3f65a7181b95e261478e (patch)
tree9a6f11f99e004e2e6348e84fe894e01820b6edbb
parentx11-wm/mutter: remove old (diff)
downloadgentoo-dcf13f76bb21a31516de3f65a7181b95e261478e.tar.gz
gentoo-dcf13f76bb21a31516de3f65a7181b95e261478e.tar.bz2
gentoo-dcf13f76bb21a31516de3f65a7181b95e261478e.zip
dev-python/docutils: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/docutils/Manifest1
-rw-r--r--dev-python/docutils/docutils-0.11.ebuild68
-rw-r--r--dev-python/docutils/files/docutils-0.11-python3.3-odt-writer.patch30
3 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/docutils/Manifest b/dev-python/docutils/Manifest
index 340341f88163..5babac211ece 100644
--- a/dev-python/docutils/Manifest
+++ b/dev-python/docutils/Manifest
@@ -1,4 +1,3 @@
-DIST docutils-0.11.tar.gz 1611755 BLAKE2B 78e377bccb949d5ba324b90e0a316b38d8874dee8b82da254b1e442516c8b5788cdafc92feb42a50bfbd5e47ea62c64a90c821d2b7921318a120f9d5600ec6c3 SHA512 8e87581b27ce4fb5e97dcef56047f4bf3a076b98e9e42f5dc66f4c370e5893d1571e46f00fee6f1c8b9f8c8a79e128e4599b9ee213ad1dee2bf16a0246e187df
DIST docutils-0.12.tar.gz 1618353 BLAKE2B c431e4f2d5ca21235bba860ae7aa4698af0f41b5bc1184bf39452f2c90fdae35d77fb52cab3b9fb5c4202541a01508d268c92c98845bbfd1d38e215e4228234d SHA512 0087433f8b76e1d0302d2fab77fdbda941132d16ac1fcecb26ca66119687eefd9e2f6901e05d705f857fa31e2526136c9827dfd57c44cd295bd10dcce3faebf9
DIST docutils-0.13.1.tar.gz 1735216 BLAKE2B 6229e7de842c6871bcc44a536333f005c5f4691423a4284d72f617bacbdbeb67c0e49e1ee74ce6ebf96e9329d0df2a5acdef306da975551108e74bd557aff4f9 SHA512 6a68b27dac3705ff532cb79d6b6808071206544a1c653e6a24d46971a5e10edffc7d275834eec4e80d948eb066bb099cae0195c0ab674e68747820e54f0ea64e
DIST docutils-0.14.tar.gz 1727105 BLAKE2B d8880918e04ae19ec17ec8aeeaeb44d198a15d7f4c300e08d50b730aa5f753e564391e796b71947c66179ad58fb99e17d11172867d804e0734a17be7dcef3b4b SHA512 1ed72c2ef7d2ca38d1c6f3154b7986ea46f599d9bd826405a5257fdd7740c8626957d6298aa95fb0edea8a24515de22f1ad9b2ecbd59341a1ab7a2bab30f500c
diff --git a/dev-python/docutils/docutils-0.11.ebuild b/dev-python/docutils/docutils-0.11.ebuild
deleted file mode 100644
index 80f1a11de170..000000000000
--- a/dev-python/docutils/docutils-0.11.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Documentation Utilities"
-HOMEPAGE="http://docutils.sourceforge.net/ https://pypi.org/project/docutils/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-3 public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/docutils-0.11-python3.3-odt-writer.patch )
-
-python_compile_all() {
- # Generate html docs from reStructured text sources.
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css . || die
-
- cd tools || die
- "${PYTHON}" buildhtml.py --input-encoding=utf-8 \
- --stylesheet-path=../html4css1.css, --traceback ../docs || die
-}
-
-python_test() {
- if python_is_python3; then
- pushd test3 > /dev/null || die
- else
- pushd test > /dev/null || die
- fi
- "${PYTHON}" alltests.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Install tools.
- python_doscript tools/{buildhtml,quicktest}.py
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-python_install_all() {
- local DOCS=( *.txt )
- local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
-
- distutils-r1_python_install_all
-
- local doc
- while IFS= read -r -d '' doc; do
- install_txt_doc "${doc}"
- done < <(find docs tools -name '*.txt' -print0)
-}
diff --git a/dev-python/docutils/files/docutils-0.11-python3.3-odt-writer.patch b/dev-python/docutils/files/docutils-0.11-python3.3-odt-writer.patch
deleted file mode 100644
index e84256f3dc43..000000000000
--- a/dev-python/docutils/files/docutils-0.11-python3.3-odt-writer.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/docutils/writers/odf_odt/__init__.py
-+++ b/docutils/writers/odf_odt/__init__.py
-@@ -88,16 +88,20 @@
- # that support for the ability to get the parent of an element.
- #
- if WhichElementTree == 'elementtree':
-- class _ElementInterfaceWrapper(etree._ElementInterface):
-+ import weakref
-+ _parents = weakref.WeakKeyDictionary()
-+ if isinstance(etree.Element, type):
-+ _ElementInterface = etree.Element
-+ else:
-+ _ElementInterface = etree._ElementInterface
-+ class _ElementInterfaceWrapper(_ElementInterface):
- def __init__(self, tag, attrib=None):
-- etree._ElementInterface.__init__(self, tag, attrib)
-- if attrib is None:
-- attrib = {}
-- self.parent = None
-+ _ElementInterface.__init__(self, tag, attrib)
-+ _parents[self] = None
- def setparent(self, parent):
-- self.parent = parent
-+ _parents[self] = parent
- def getparent(self):
-- return self.parent
-+ return _parents[self]
-
-
- #