summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-22 02:18:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-22 02:21:56 +0200
commitdd68af9139cfb2a6c0a5a1df730c480b6f8197f8 (patch)
treec6f643f6a9b620df8a5b379a65f782d51aac64ab
parentdev-lang/python: bump to 2.7.12 (diff)
downloadgentoo-dd68af9139cfb2a6c0a5a1df730c480b6f8197f8.tar.gz
gentoo-dd68af9139cfb2a6c0a5a1df730c480b6f8197f8.tar.bz2
gentoo-dd68af9139cfb2a6c0a5a1df730c480b6f8197f8.zip
sci-libs/fftw: Don't check for openmp toolchain when installing a binpkg.
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sci-libs/fftw/fftw-3.3.4.ebuild5
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild4
2 files changed, 3 insertions, 6 deletions
diff --git a/sci-libs/fftw/fftw-3.3.4.ebuild b/sci-libs/fftw/fftw-3.3.4.ebuild
index c0e4b6f4a20..a1e5ebf30b3 100644
--- a/sci-libs/fftw/fftw-3.3.4.ebuild
+++ b/sci-libs/fftw/fftw-3.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,8 +33,7 @@ DEPEND="${RDEPEND}
test? ( dev-lang/perl )"
pkg_setup() {
- # XXX: this looks like it should be used with BUILD_TYPE!=binary
- if use openmp; then
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
ewarn "OpenMP is not available in your current selected gcc"
die "need openmp capable gcc"
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
index 1b2fc028af0..ec07ce4c95d 100644
--- a/sci-libs/fftw/fftw-9999.ebuild
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -38,9 +38,7 @@ MULTILIB_WRAPPED_HEADERS=(
)
pkg_setup() {
- # XXX: this looks like it should be used with BUILD_TYPE!=binary
-
- if use openmp; then
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
ewarn "OpenMP is not available in your current selected gcc"
die "need openmp capable gcc"