summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-03 17:11:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-03 17:16:35 +0100
commitddb96ada05529f3ff7cda3848534bf6145b7dfca (patch)
treeb7bc4f83bd55852af4801f0e0e56476470871771
parentdev-java/mersennetwister: EAPI 5 bump. Switch to java-pkg-simple. (diff)
downloadgentoo-ddb96ada05529f3ff7cda3848534bf6145b7dfca.tar.gz
gentoo-ddb96ada05529f3ff7cda3848534bf6145b7dfca.tar.bz2
gentoo-ddb96ada05529f3ff7cda3848534bf6145b7dfca.zip
apache-2.eclass: Doesn't work with EAPI-6 yet.
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--eclass/apache-2.eclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index e07693da2bd..3f9e706f8b9 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -17,7 +17,13 @@ inherit autotools eutils flag-o-matic multilib ssl-cert user toolchain-funcs ver
case ${EAPI:-0} in
0|1|2|3|4)
- die "This eclass requires >=EAPI-5"
+ die "This eclass is banned for EAPI<5"
+ ;;
+ 5)
+ :;
+ ;;
+ 6)
+ die "This eclass is not yet ready for EAPI-6"
;;
esac