summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-03-27 17:22:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-04-05 15:32:43 +0300
commitde01b95fdc40343d89d0eff77cd34a34473c5354 (patch)
treeabe0c8ecb87e6dbc4a1b4966f879be166facd09c
parentapp-forensics/yara: add 9999 (diff)
downloadgentoo-de01b95fdc40343d89d0eff77cd34a34473c5354.tar.gz
gentoo-de01b95fdc40343d89d0eff77cd34a34473c5354.tar.bz2
gentoo-de01b95fdc40343d89d0eff77cd34a34473c5354.zip
dev-python/yara-python: add 4.3.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/yara-python/Manifest1
-rw-r--r--dev-python/yara-python/yara-python-4.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
index 220814f1fb58..cb89bd05dcc7 100644
--- a/dev-python/yara-python/Manifest
+++ b/dev-python/yara-python/Manifest
@@ -1 +1,2 @@
DIST yara-python-4.2.3.gh.tar.gz 34465 BLAKE2B 4b9689cef21f9c712960d08c357087f0278d8c20cef3a16072a005a4f8687999aa273c02c22ea9c6d5ea9a6b609c1a6f4c51f01b04f238e9e1faeeaef275d88b SHA512 588875d820f4e1b2aa5c6bbe83814ba2756f5ed301ba652efd280d5ca9745f7388f1f9eaa3875d11de5644ce9c41dcb76eebbee86269f8d6723c7d16ffa134be
+DIST yara-python-4.3.0.gh.tar.gz 37826 BLAKE2B 2a06e462af5b3ef5098b650687f1953e51f53858dc9c22b0e9358641fa20f3f5c2b7f3b824b5b8195408e3e2bfaa05afedc851a326486454d9f3eadeecd3fe33 SHA512 c45bb57179b4191e6fb5577f42abb280dad91832720ad1712de8a2ea42adc5e3604079b2d8d0020ba86ece4043e7488889a54677e10cd2bc172a1480e57f1fef
diff --git a/dev-python/yara-python/yara-python-4.3.0.ebuild b/dev-python/yara-python/yara-python-4.3.0.ebuild
new file mode 100644
index 000000000000..a4fa9fa8737f
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara-python.git"
+else
+ SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =app-forensics/yara-$(ver_cut 1-2)*
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic_linking = True
+ EOF
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}