summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-15 04:35:53 +0000
committerSam James <sam@gentoo.org>2020-11-15 04:35:53 +0000
commitde47aee45fc4d78212179938093608c03ce7cbeb (patch)
tree56dd2847078c945771140b8996ad8fad24b78700
parentapp-emulation/wine-vanilla: Stabilize 5.0.2 amd64, #753443 (diff)
downloadgentoo-de47aee45fc4d78212179938093608c03ce7cbeb.tar.gz
gentoo-de47aee45fc4d78212179938093608c03ce7cbeb.tar.bz2
gentoo-de47aee45fc4d78212179938093608c03ce7cbeb.zip
sci-libs/cln: fix build failure
autotools-utils can do out-of-source builds, and it does by default, but we need to invoke autotools-utils_src_configure for it to have the right behaviour. This is counterintuitive given more modern examples like CMake use src_prepare for the same functionality. Fixes: 785c90cfa242ac84cff475d5ec5e7f0ed64c14c3 Bug: https://bugs.gentoo.org/725420 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/cln/cln-1.3.3.ebuild3
-rw-r--r--sci-libs/cln/cln-1.3.4.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sci-libs/cln/cln-1.3.3.ebuild b/sci-libs/cln/cln-1.3.3.ebuild
index a8823500d1ed..9687c7bb01a1 100644
--- a/sci-libs/cln/cln-1.3.3.ebuild
+++ b/sci-libs/cln/cln-1.3.3.ebuild
@@ -36,7 +36,8 @@ src_prepare() {
}
src_configure() {
- econf --disable-static
+ local myeconfargs=( --disable-static )
+ autotools-utils_src_configure
}
src_compile() {
diff --git a/sci-libs/cln/cln-1.3.4.ebuild b/sci-libs/cln/cln-1.3.4.ebuild
index da31581523ef..29ac33c74b05 100644
--- a/sci-libs/cln/cln-1.3.4.ebuild
+++ b/sci-libs/cln/cln-1.3.4.ebuild
@@ -36,7 +36,8 @@ src_prepare() {
}
src_configure() {
- econf --disable-static
+ local myeconfargs=( --disable-static )
+ autotools-utils_src_configure
}
src_compile() {