summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-14 07:41:48 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-14 07:43:47 +0200
commitde4fb900ba081d717940122535875010d657c74f (patch)
tree9b2059b0fe426ce27b6d99167f80bdc9ddc89d0c
parentdev-util/ccache: keyword 4.6-r1 for ~loong (diff)
downloadgentoo-de4fb900ba081d717940122535875010d657c74f.tar.gz
gentoo-de4fb900ba081d717940122535875010d657c74f.tar.bz2
gentoo-de4fb900ba081d717940122535875010d657c74f.zip
dev-ruby/activesupport: add 5.2.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.2.8.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 5794aa721f34..a3a590430e5c 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,5 +1,6 @@
DIST rails-5.2.6.tgz 8841270 BLAKE2B 8e813f376446ef249aa3b48934d3cb5ae125c09c54353cc93557c3bee4f23e47ae7ceffab75d5cbfb691daed85149d9054337b468a0010bc5c7ebb879502396b SHA512 465e017591a9962a2e0dec2eac9669d5f507d0904e9eec50fbc8848d804ba5f1eb3220fd5acc949845f048f59cfc5e43f099707650edf301d6595e70e33888c7
DIST rails-5.2.7.1.tgz 8847972 BLAKE2B 13e5f47431a7611c1fe7ed490198a81634670460effdb14e6657bbc3455388da26db6a611f363b93b35e25a6d2693f227ef2be960d432770afd63906a2ca2b4f SHA512 64b155d522a944eed7ba08417423ebc8b3a6d2ecd39940021c37f54ae3af649d0de6dc1794b4b295d4874eb58cb17bf11d285daa146f37113c42c3aed9cc39c6
+DIST rails-5.2.8.tgz 8847449 BLAKE2B 11937ee2aeea39cade43829a01430315a997fef070fc73a1e63baaff8b3631f82561c7acdd44cf1981501424be68d814001dd26cbf7678ca987a8311d109d367 SHA512 98e1b36bdd4235e983d0805b6ff9779e3793d1bed486dc6de854215c4294334d5036157a527c1222cc2be4c107754553dadf2bf86e65ce6561dd8152c47ef84a
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
DIST rails-6.0.4.4.tgz 18594292 BLAKE2B 8f463900db30ffd4850b270aac0ae8c160af36a606e4eddaadbd2a0c086de3438a36665586e20a4b6b8873f8b659f2ecd3e32965a36118a6e63fad2726afa0f5 SHA512 14f7d51ba407589eb4ef1db8a99c21c301198e8cb2fcdf611c76eebd1d52192eb1225bb5d45a2183fbfe103a0b987f3a95c6c5fe6d772ba101da9ed46441441f
DIST rails-6.0.4.7.tgz 18596833 BLAKE2B a376bed4a0531147bbeb2c147e6067657313b5e0ffc713b18d07037177eaeeade1516197533b022afd9b0b03a1f2ed130b85600af3ea7d53a7d932db1e6f4342 SHA512 e4220411ed28b2e28002820281923b45d90454ef59a57b57c98bad5e185d39b2af75609e7786566135b5e1b197544cc039ad81df1a663eeebfa10728ae2904d1
diff --git a/dev-ruby/activesupport/activesupport-5.2.8.ebuild b/dev-ruby/activesupport/activesupport-5.2.8.ebuild
new file mode 100644
index 000000000000..388b98e624c0
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ dev-ruby/i18n:1
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '1igem "tzinfo", "~> 1.1"; gem "psych", "~> 3.0"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+}