summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-31 16:20:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-31 16:20:25 +0100
commitde6424e06fc86d2117b4a6eb29a23f7a394e3a21 (patch)
tree9e1b8ca193a7a044d6414682f310862915b6b5de
parentkde-frameworks/extra-cmake-modules: Update patch by upstream review (diff)
downloadgentoo-de6424e0.tar.gz
gentoo-de6424e0.tar.bz2
gentoo-de6424e0.zip
dev-libs/liborcus: 0.13.2 version bump
Package-Manager: Portage-2.3.21, Repoman-2.3.6
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.13.2.ebuild57
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild2
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 8c40a53c4028..30f536fc3b16 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,2 +1,3 @@
DIST liborcus-0.12.1.tar.xz 1673880 BLAKE2B 6f85f1ce04bd7c797f8fccc9b4d860189b6fa9f51623587a668c343e8897bf17a3e62a5465354776044fabe9347ec35913eb1433dc551e4e509ce260ba92c3b9 SHA512 294b24ad7fccae77070edd9d8e6e1a370f609ec8af9a2c58567431e641fc0f3f27c4cd4b6ac1825a8179a22a1d1a81d84827859eb631d2625194f9e59ca1a8c3
DIST liborcus-0.13.1.tar.xz 1814552 BLAKE2B 27c31a2a6ab2de392aeb36d72417184c37d6f76707b570a0beed53d4b817fd093758381ad4b0e64258d3d9d7d9d9434dfa0be447d9a6c28f47af6fb7496c1a6e SHA512 1c81332974cada2d3526e86ef564211100fb765b611a2239fe6aaabb8666e38a7c8cb52696e5d7c402794ea5b5ceb23b083f7adf2c4417d2e635007d9baa4420
+DIST liborcus-0.13.2.tar.xz 1816884 BLAKE2B e9e7635969cdeb2dcf7274a9d54774ba3b49a40db203624e7351eaca6dfe8c87605a1a5ff8c844f50faa47b88379504cc48a3aa432f75c1d00e5974ef244b93a SHA512 3f79787a62ee0ab59ee61d5b46e1e777b27529e20d6dde9a98db75c8b6c54a11f5f78fa46d018bb31a9ef9df19a60535936e645e5fa43e71bd4e25d9f3a802b7
diff --git a/dev-libs/liborcus/liborcus-0.13.2.ebuild b/dev-libs/liborcus/liborcus-0.13.2.ebuild
new file mode 100644
index 000000000000..2f6e72a16cd9
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.13.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.13" # based on SONAME of liborcus.so
+# [[ ${PV} == 9999 ]] || \
+# KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="python +spreadsheet-model static-libs tools"
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( >=dev-libs/libixion-0.13.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.2:1
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable python) \
+ $(use_enable spreadsheet-model) \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index e2c9f8f07405..a4d905a62839 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6