summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-24 00:00:40 +0100
committerSam James <sam@gentoo.org>2022-08-24 00:00:40 +0100
commitde903fb0a0494026c3e787d1c0d922f77b0179f2 (patch)
treee756d434035515199d83d0f3672acf4cb2e040e4
parentsys-boot/plymouth: fix build w/ glibc 2.36 (diff)
downloadgentoo-de903fb0a0494026c3e787d1c0d922f77b0179f2.tar.gz
gentoo-de903fb0a0494026c3e787d1c0d922f77b0179f2.tar.bz2
gentoo-de903fb0a0494026c3e787d1c0d922f77b0179f2.zip
net-fs/samba: fix build w/ glibc 2.36
Closes: https://bugs.gentoo.org/863830 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-fs/samba/files/samba-4.16.4-glibc-2.36.patch51
-rw-r--r--net-fs/samba/samba-4.16.4.ebuild1
2 files changed, 52 insertions, 0 deletions
diff --git a/net-fs/samba/files/samba-4.16.4-glibc-2.36.patch b/net-fs/samba/files/samba-4.16.4-glibc-2.36.patch
new file mode 100644
index 000000000000..7d3d231f50c9
--- /dev/null
+++ b/net-fs/samba/files/samba-4.16.4-glibc-2.36.patch
@@ -0,0 +1,51 @@
+https://gitlab.com/samba-team/samba/-/commit/df7d6f0c48612feea428643006d32c2292c662e2
+https://bugs.gentoo.org/863830
+
+From: Andreas Schneider <asn@samba.org>
+Date: Tue, 2 Aug 2022 07:55:46 +0200
+Subject: [PATCH] lib:replace: Only include <sys/mount.h> on non-Linux systems
+
+Details at:
+https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
+
+BUG: https://bugzilla.samba.org/show_bug.cgi?id=15132
+
+Signed-off-by: Andreas Schneider <asn@samba.org>
+Reviewed-by: Ralph Boehme <slow@samba.org>
+(cherry picked from commit 766151bf5b7ef95ae4c8c98b8994e5c21c5bbec0)
+
+Autobuild-User(v4-16-test): Jule Anger <janger@samba.org>
+Autobuild-Date(v4-16-test): Tue Aug 23 08:53:41 UTC 2022 on sn-devel-184
+--- a/lib/replace/system/filesys.h
++++ b/lib/replace/system/filesys.h
+@@ -36,7 +36,8 @@
+ #include <sys/param.h>
+ #endif
+
+-#ifdef HAVE_SYS_MOUNT_H
++/* This include is required on UNIX (*BSD, AIX, ...) for statfs() */
++#if !defined(LINUX) && defined(HAVE_SYS_MOUNT_H)
+ #include <sys/mount.h>
+ #endif
+
+@@ -44,6 +45,7 @@
+ #include <mntent.h>
+ #endif
+
++/* This include is required on Linux for statfs() */
+ #ifdef HAVE_SYS_VFS_H
+ #include <sys/vfs.h>
+ #endif
+--- a/lib/replace/wscript
++++ b/lib/replace/wscript
+@@ -31,6 +31,9 @@ def configure(conf):
+
+ conf.env.standalone_replace = conf.IN_LAUNCH_DIR()
+
++ if sys.platform.rfind('linux') > -1:
++ conf.DEFINE('LINUX', '1')
++
+ conf.DEFINE('BOOL_DEFINED', 1)
+ conf.DEFINE('HAVE_LIBREPLACE', 1)
+ conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
+GitLab
diff --git a/net-fs/samba/samba-4.16.4.ebuild b/net-fs/samba/samba-4.16.4.ebuild
index 0285da3c90ea..dfcb1a1d920c 100644
--- a/net-fs/samba/samba-4.16.4.ebuild
+++ b/net-fs/samba/samba-4.16.4.ebuild
@@ -144,6 +144,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.16.1-netdb-defines.patch"
"${FILESDIR}/${PN}-4.16.2-fix-musl-without-innetgr.patch"
"${FILESDIR}/ldb-2.5.2-skip-wav-tevent-check.patch"
+ "${FILESDIR}/${P}-glibc-2.36.patch"
)
#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"