summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-11-05 17:13:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-11-05 17:13:36 +0000
commitdeb9170373e56985b2938e95ccf042cfa3350f5e (patch)
treea9c2736df1ef89d5a166f1c3acda6b2ce81af582
parentsys-kernel/linux-docs: Linux documentation for patch version 4.2.5 (diff)
downloadgentoo-deb9170373e56985b2938e95ccf042cfa3350f5e.tar.gz
gentoo-deb9170373e56985b2938e95ccf042cfa3350f5e.tar.bz2
gentoo-deb9170373e56985b2938e95ccf042cfa3350f5e.zip
net-p2p/qbittorrent: Version bump
Package-Manager: portage-2.2.23
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.2.5.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index ce155a5f52b8..f689d3e8c6e0 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -3,3 +3,4 @@ DIST qbittorrent-3.1.9.2.tar.xz 2231708 SHA256 b07ccdbe1ae079f781c62aff21d47183a
DIST qbittorrent-3.2.0.tar.xz 2595372 SHA256 51781cb121ebeda041fb348e649c4bd97888ee8c1d18328bc547d447b960d1b3 SHA512 0e652a4045d2e034611484009c1ce60c0b365fb6030356ac740555bca3e77f901228a24f21fddc87501f39b737ac15cfff4d3d9a18c913ab03df4d90ceb48634 WHIRLPOOL 5c3d215735a70fcbe01773d3a6676209719d91b25ee5ac68f12767fdfd1108626556802cb58f5e698a80607ad3550b5dea0c97670fdc3d6a4975546da3436b1b
DIST qbittorrent-3.2.3.tar.xz 2638708 SHA256 86a79f3772bd06736a4be104180187d76c5c8feb2c1cdf1054135b4ba602a914 SHA512 304635f4942776f6be5987ad6a60e2e0e217c913bbe3637cef2dd0bfc65450b894e88c639c96d856d3e937f40d120acc62c194bcb29ae52070ad51e921edbdf7 WHIRLPOOL 33728a4679ef9731645a937c059633d18ff4673ded258185488bc31aab001fe720ab3e3aef23bd8d36f1cf12e98d96ed7383d5cc5b3ecbfa2b065028ddacc4ce
DIST qbittorrent-3.2.4.tar.xz 2664248 SHA256 7fc128e2809c3be4ea543cfaeefd922e0327cc430330eaad0d3ec7616df51871 SHA512 c86098d791b64bd5f0ef6b465cf3eb6f1016402b33b18ba927279f521d768aa973d3f233794adb63820c5bca7e67672bf3c64fe65a7e5bf513219f860d2b2141 WHIRLPOOL c5690fdf01a8841978404e61369a16da13dd27c151618cadbb4e16add7d5377d980d9a94cea68f82005c88bd4b637a23f0ea6fb2615c3921302c5847e0763272
+DIST qbittorrent-3.2.5.tar.xz 2665980 SHA256 98f69c7324276c7c144738eb36b21a2d28d7f01a327104568f020887626e822b SHA512 a98c1cf8607558990d0698c50d35cd217bceeb4deffe69c590f902b1a9dabc5431496805614dbd3bb734f764c309023ede2f8a5cb014f40796301fa14ba63e90 WHIRLPOOL 6539bde802919351836d1bb2d880d5b28d51c97b109674f2ae3e54c9aa9ab52c5e58436371a34b7388d119d041cf9b2a597656e338808243309cbf631e03fe2b
diff --git a/net-p2p/qbittorrent/qbittorrent-3.2.5.ebuild b/net-p2p/qbittorrent/qbittorrent-3.2.5.ebuild
new file mode 100644
index 000000000000..d6e90af8190f
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.2.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+MY_P=${P/_}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug +qt4 qt5 webui +X"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
+ >=net-libs/rb_libtorrent-1.0.6
+ sys-libs/zlib
+ qt4? (
+ dev-qt/qtcore:4
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? ( dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ )
+"
+DEPEND="${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_prepare() {
+ epatch_user
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use qt5 && echo --with-qt5)
+ $(use webui || echo --disable-webui)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ use qt4 && eqmake4
+ use qt5 && eqmake5
+}