summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 08:10:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 08:10:56 +0200
commitdec727090083f7a7e3e3fa1d2dfd26ad8ff5be50 (patch)
tree999a72d4a3b736bc8bddf0dd36d43a1fb32e1663
parentdev-python/keyring: Port to py39 (diff)
downloadgentoo-dec727090083f7a7e3e3fa1d2dfd26ad8ff5be50.tar.gz
gentoo-dec727090083f7a7e3e3fa1d2dfd26ad8ff5be50.tar.bz2
gentoo-dec727090083f7a7e3e3fa1d2dfd26ad8ff5be50.zip
dev-python/pytest: Increase timeouts in 4.6.10 for slower machines
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest/files/pytest-4.6.10-timeout.patch35
-rw-r--r--dev-python/pytest/pytest-4.6.10.ebuild1
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest/files/pytest-4.6.10-timeout.patch b/dev-python/pytest/files/pytest-4.6.10-timeout.patch
new file mode 100644
index 000000000000..5bf9bcdbd8f5
--- /dev/null
+++ b/dev-python/pytest/files/pytest-4.6.10-timeout.patch
@@ -0,0 +1,35 @@
+diff --git a/src/_pytest/pytester.py b/src/_pytest/pytester.py
+index f1d739c99..72406b85d 100644
+--- a/src/_pytest/pytester.py
++++ b/src/_pytest/pytester.py
+@@ -1209,7 +1209,7 @@ class Testdir(object):
+ args = self._getpytestargs() + args
+ return self.run(*args, timeout=timeout)
+
+- def spawn_pytest(self, string, expect_timeout=10.0):
++ def spawn_pytest(self, string, expect_timeout=60.0):
+ """Run pytest using pexpect.
+
+ This makes sure to use the right pytest and sets up the temporary
+@@ -1223,7 +1223,7 @@ class Testdir(object):
+ cmd = "%s --basetemp=%s %s" % (invoke, basetemp, string)
+ return self.spawn(cmd, expect_timeout=expect_timeout)
+
+- def spawn(self, cmd, expect_timeout=10.0):
++ def spawn(self, cmd, expect_timeout=60.0):
+ """Run a command using pexpect.
+
+ The pexpect child is returned.
+diff --git a/testing/test_terminal.py b/testing/test_terminal.py
+index 1b2e46c7c..52ba80f46 100644
+--- a/testing/test_terminal.py
++++ b/testing/test_terminal.py
+@@ -138,7 +138,7 @@ class TestTerminal(object):
+ """
+ def test_1():
+ import time
+- time.sleep(20)
++ time.sleep(120)
+ """
+ )
+ child = testdir.spawn_pytest("")
diff --git a/dev-python/pytest/pytest-4.6.10.ebuild b/dev-python/pytest/pytest-4.6.10.ebuild
index 76710136e68b..c8234af1fa7a 100644
--- a/dev-python/pytest/pytest-4.6.10.ebuild
+++ b/dev-python/pytest/pytest-4.6.10.ebuild
@@ -60,6 +60,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${PN}-4.5.0-strip-setuptools_scm.patch"
+ "${FILESDIR}/${P}-timeout.patch"
)
python_prepare_all() {