summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-01 19:33:35 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-01 20:05:42 +0200
commitdece59f344deb05efb01fa2d99be43af8b15600d (patch)
treeca8fad119e5394c0b16249238f071c64afbb8d48
parentdev-lang/ruby: cleanup (diff)
downloadgentoo-dece59f344deb05efb01fa2d99be43af8b15600d.tar.gz
gentoo-dece59f344deb05efb01fa2d99be43af8b15600d.tar.bz2
gentoo-dece59f344deb05efb01fa2d99be43af8b15600d.zip
app-office/unoconv: add 0.9
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--app-office/unoconv/Manifest1
-rw-r--r--app-office/unoconv/unoconv-0.9.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-office/unoconv/Manifest b/app-office/unoconv/Manifest
index 5635e3bba291..3eeda75840c3 100644
--- a/app-office/unoconv/Manifest
+++ b/app-office/unoconv/Manifest
@@ -1 +1,2 @@
DIST unoconv-0.8.2.tar.gz 104072 BLAKE2B 1ac16159f939a06cc75f3ff23f5aa7f1c4d49a41d4cce5e9c5866714ef1b3b969f94c074d36fff19d6af22375d5598033fb69761a09d3e60b81d794841c0e0d8 SHA512 cd6a4d06559895c0aebb5fda51ca86928474dd0ca0aa908e81762643186c29cf8436c889eedbb18bc74ed6016414d1aa831cd034614244d5aae677a6b4cdd4c9
+DIST unoconv-0.9.tar.gz 108547 BLAKE2B 6620a7adb32c25182fbb5d0b141ec15d461ee7a73d8644e92337fd7748607d0d33a5978add4c72abf2b35f769f8bbfa35d411f77c4750606e22d6cbc7d7b3454 SHA512 1d6448154ec41776ed4d2ffd87b1caa15e231676a1161072676b1f5a466ea6dbae904de3eafb9ab2718fe4ed0ab7a2c9a91b1d19d79ea382c1e7576ea21e7f04
diff --git a/app-office/unoconv/unoconv-0.9.ebuild b/app-office/unoconv/unoconv-0.9.ebuild
new file mode 100644
index 000000000000..1b1189bb0d81
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit eutils python-single-r1
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+src_prepare() {
+ eapply "${FILESDIR}/timeout.patch"
+ eapply_user
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog CHANGELOG.md README.adoc || die
+}