summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-07 09:55:27 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-07 19:28:43 -0500
commitdf4f9e229cd80c9dc6ec9464ede266678be0fcd9 (patch)
treee751c08341dd6c7a446e64e4842a3b9088a0d4e3
parentdev-python/django: Use verify-sig.eclass (diff)
downloadgentoo-df4f9e229cd80c9dc6ec9464ede266678be0fcd9.tar.gz
gentoo-df4f9e229cd80c9dc6ec9464ede266678be0fcd9.tar.bz2
gentoo-df4f9e229cd80c9dc6ec9464ede266678be0fcd9.zip
dev-libs/gobject-introspection-common: Version bump to 1.66.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/gobject-introspection-common/Manifest1
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.66.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index 96f70b59b14f..946bd1480d7d 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1,2 +1,3 @@
DIST gobject-introspection-1.62.0.tar.xz 980732 BLAKE2B 96ecc98bea97b7cb24e2c0a0adb8158cfc8915ee8e3b980adf08ec3256d4d0f87bc92d33cce30f5b23c85c4b144d8da755e5313735091b27ff53fea45a80014e SHA512 b460a95fd7a323e9b0c9a45e680ebe98bbae7632abfa53b3e0b0ec050775cab17dde693314d6d4f8e93614c32b5587f8ce0b4a4c9ee9ba46c029ce029014e638
DIST gobject-introspection-1.64.1.tar.xz 1000280 BLAKE2B c0248831648f6f1849516f30facac9ecade4b4fdb9dce70f93f516364c08f93d0622e06376bd7895dd25c3f1fb5b0af533d6c60f1b2590848cc6781b81a584f4 SHA512 7610871f7ed5778ea9813062ed6465d131af58c00bdea1bb51dde7f98f459f44ae453eb6d0c5bdc6f7dcd92d639816f4e0773ccd5673cd065d22dabc6448647c
+DIST gobject-introspection-1.66.1.tar.xz 1012784 BLAKE2B dd3faa70a482016c9d45b41a62eb1708b775979b92a466c45e70fa9f7679f3931467f5f41a30ecf2260afdd5759218f0afe68b82901587d7cf9267b1fe59d4e8 SHA512 ea1e20cd94ff8af3572f417f35e96648ffc3e94a91d4e4c81adf99bb0f408ac21ecf40990f9dbd5f2e0f4e83360286ca5db88dbc45bd59289596a324acf7df3d
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.66.1.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.66.1.ebuild
new file mode 100644
index 000000000000..08b6851ff4fb
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.66.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}