summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-29 23:46:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-29 23:46:05 +0100
commitdf5b886a149e4904166c8be7de8028e5c9345edf (patch)
tree80e8e5dabd0468252c78be144ca351d23ad9d919
parentapp-shells/zsh-completions: Stable on amd64 (diff)
downloadgentoo-df5b886a149e4904166c8be7de8028e5c9345edf.tar.gz
gentoo-df5b886a149e4904166c8be7de8028e5c9345edf.tar.bz2
gentoo-df5b886a149e4904166c8be7de8028e5c9345edf.zip
dev-libs/libinput: Version bump to 1.5.2
Package-Manager: portage-2.3.2
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.5.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index a68e244c260c..36ceeaaa1ef2 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -5,3 +5,4 @@ DIST libinput-1.3.3.tar.xz 881992 SHA256 30c8edfe47654a38c235ac6b0541d79fd593d01
DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4
DIST libinput-1.5.0.tar.xz 910476 SHA256 5a96559385ecfaa30f9e72ea89eb8ebbc97caf68e458f451f4ed62315311081c SHA512 801b7a161d85f6e5f4ce03f3bc7e367ee22646cc8994e2660697d23af99ad2a91c0824e8bfc039b294ce4eac4c808697b3caf22b7b6587a201e8e75519be0a3a WHIRLPOOL 0b97ff67a45f46771a507a36ad09775e4be1c934b87cb0231b7a6d682a6043f0e8ba0efbd7f3321c461f0a9292d9f7ef0f58d7cffc17d9685ae1c6128856e76d
DIST libinput-1.5.1.tar.xz 926872 SHA256 d4f63933b0967bd691735af5e3919e2d29c2121d4e05867cc4e10ff3ae8e2dd8 SHA512 13cf61ec3cc67687ee4cbe6fffd1cec722d4c0b328f5fddc9e0c655af1cdc5030b3cebeb32374917df2bd14eeee74e2be9ea97af52d006e08f447932bf525e9a WHIRLPOOL eceebd33bb530f5c673deca743980d2b5c39c24a7eff49c1bfa4f15f23b104d5173fd62a433f1d1881aa4362b4203fa8944a738350124720034e692b2e9af5ea
+DIST libinput-1.5.2.tar.xz 926048 SHA256 ba26e2bc64ed551eaef193178ed06b07b97a09ac6f4e442f5f15bbc3f3174682 SHA512 a3552f36fc91b523caceb128d048a0a7161335aef78554f202011fcc9acfb5f772d2124a4441f0f542f1b8051b8a2ecb7b00fad5456d8c06b213b96b9ebc91de WHIRLPOOL 025cd1b3261a977b2a579e03766939a443b6fa26b486e9fa16e445b39acf5d31b1f74260670b74718e5d11648c459b42b546e2311d5cac8a713a8a5b0e893791
diff --git a/dev-libs/libinput/libinput-1.5.2.ebuild b/dev-libs/libinput/libinput-1.5.2.ebuild
new file mode 100644
index 000000000000..8ec94bd29692
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}