summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-01 22:59:44 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-01 22:59:52 +0100
commitdfaba443b3bee43a7cd3bca699a899453754a1a8 (patch)
treee5b794c4de89aae1daa21c8e9c67f4555bc0dc98
parentdev-php/adodb: bump to v5.20.20 (diff)
downloadgentoo-dfaba443b3bee43a7cd3bca699a899453754a1a8.tar.gz
gentoo-dfaba443b3bee43a7cd3bca699a899453754a1a8.tar.bz2
gentoo-dfaba443b3bee43a7cd3bca699a899453754a1a8.zip
sys-power/uhubctl: bump to v2.3.0
Closes: https://github.com/gentoo/gentoo/pull/19163 Closes: https://bugs.gentoo.org/763936 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-power/uhubctl/Manifest1
-rw-r--r--sys-power/uhubctl/uhubctl-2.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-power/uhubctl/Manifest b/sys-power/uhubctl/Manifest
index 1a41656f34de..647ffaacfa12 100644
--- a/sys-power/uhubctl/Manifest
+++ b/sys-power/uhubctl/Manifest
@@ -1 +1,2 @@
DIST uhubctl-1.8.tar.gz 16158 BLAKE2B 1203e9711716987c0f60786cfe48a92a9a9a78f4bceb3851889a305a1289772375c6a512c361ba1e3e937fa1cb2f64e07365ef494e248e07a7a4f45f9e78c451 SHA512 fcc88ca47467e8e6085a75461495393306ddff1d6f7c9184c129bbdd044451b6430ac916f648b9f71c798054373f3d9102185e3d0c8f355c47e2574a1984ec9d
+DIST uhubctl-2.3.0.tar.gz 25367 BLAKE2B 7e5b6bf5f4a76e90a78292b23127af366e3388ffb8565fc1d763b9bd45faf0518411996a307a42c62827006ef9488e39282c95b2ba6c0bc289863cec7c91ac25 SHA512 e1ddc8d20b626e99facd8b0e6b746e2fdcaec667c7b280b656aa608b7990cfac1ea3e5379e89d0b1be8756ba5e91485ad003eb2bd5dfb3cc3c9cdf3d18ad1bd3
diff --git a/sys-power/uhubctl/uhubctl-2.3.0.ebuild b/sys-power/uhubctl/uhubctl-2.3.0.ebuild
new file mode 100644
index 000000000000..094e1cc2428c
--- /dev/null
+++ b/sys-power/uhubctl/uhubctl-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="USB hub per-port power control"
+HOMEPAGE="https://github.com/mvp/uhubctl"
+SRC_URI="https://github.com/mvp/uhubctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/^GIT_VERSION/#&/" \
+ Makefile \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}