summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-02 15:57:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 23:40:47 +0100
commite0111ad5724381c50bab5911be5a5cfe5a6c57d6 (patch)
tree61218c32415699921b089eb8a710a95ec1b7de9d
parentdev-qt: Add Qt 5.15.2 (diff)
downloadgentoo-e0111ad5724381c50bab5911be5a5cfe5a6c57d6.tar.gz
gentoo-e0111ad5724381c50bab5911be5a5cfe5a6c57d6.tar.bz2
gentoo-e0111ad5724381c50bab5911be5a5cfe5a6c57d6.zip
qt5-build.eclass: Limit RDEPEND on qtchooser to Qt versions <5.15.2
Qt 5.15.2 and above will depend on dev-qt/qtchooser selectively. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--eclass/qt5-build.eclass7
1 files changed, 3 insertions, 4 deletions
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index ad7f6a64a44..dce88d642cc 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -112,10 +112,9 @@ BDEPEND="
if [[ ${PN} != qttest ]]; then
DEPEND+=" test? ( ~dev-qt/qttest-${PV} )"
fi
-RDEPEND="
- dev-qt/qtchooser
-"
-
+if ver_test ${PV} -lt 5.15.2; then
+ RDEPEND+=" dev-qt/qtchooser"
+fi
###### Phase functions ######