summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 11:06:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:11:59 +0300
commite01c555f46343fe9b9d24ef293ea9c6e8d25b1ae (patch)
tree6f54c600f9c94b10b874bc8a36d1aa9d08a4ad36
parentdev-python/pypugjs: add 5.9.12 (diff)
downloadgentoo-e01c555f46343fe9b9d24ef293ea9c6e8d25b1ae.tar.gz
gentoo-e01c555f46343fe9b9d24ef293ea9c6e8d25b1ae.tar.bz2
gentoo-e01c555f46343fe9b9d24ef293ea9c6e8d25b1ae.zip
dev-python/meson-python: add 0.8.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.8.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 4c6858f6c287..1e3d198dbc6f 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,3 +1,4 @@
DIST meson-python-0.6.0.gh.tar.gz 26783 BLAKE2B d5c5b95d5d609487a0efee1ce05b133794705cdb16f2d05d6e08b9201541e31f61a832c7770b4b5ad675f8dd91860c30c67769ce8fc0af2c48e65b0aad187ddb SHA512 25042ea030d2ad323c67daa0a520db936a4a4efa0de1c9f631c47fac22d797e01d1f1707ed407e2931164a35b3916e19a774ee16ab1d45fc91e41c75add57fa1
DIST meson-python-0.7.0.gh.tar.gz 28959 BLAKE2B 6b60855d19c7dbbc4c8aca474ad55d4ce2a5db553ba86d2831adea7138d540433733d3b8e4077bf7314a6e6b68cd15b538b336afecaff3b262ae6d2157d8d5f0 SHA512 df529a3d31c67199cf72700734ea62b0de4f8eb03b437af9b53968e37c0350cbe60ba7385f8c3026d66fe2050df4c59912bf65e4a6e62ce19bace52fdcfef2e7
DIST meson-python-0.8.0.gh.tar.gz 29367 BLAKE2B bf501ef73baa5481f5367b642cefca5a8b8655b4d74776aea21f0be4608c3e42d765f17ffdd037f39e7fc9c48d162293f93af61a30533e1823a66de5151ec1f9 SHA512 1709cdf3b357970566b25958cead88be2062e35ee8576275d0ca2571eca1f6a0211986b2693af0944026f2693511729b9d5cb30279952c65a287fa510c19186d
+DIST meson-python-0.8.1.gh.tar.gz 29353 BLAKE2B 13d6ab25da404301bddb2fb7eaaeb5af256efb5ce6d09581e4a8fa90d21c3a45cc8f455b09dc99b454e8457b55eb41261743c6ffd612c6c674ac9a28bcb98f51 SHA512 e46f6dbbcc2b5f89b17c7ea3f00e8ff9d68cad458bcbfe462e09de8e0074316c15f71fd88304ccf65cc42d98b193bcc0b3547be3ec2519e8c25d31556beb1468
diff --git a/dev-python/meson-python/meson-python-0.8.1.ebuild b/dev-python/meson-python/meson-python-0.8.1.ebuild
new file mode 100644
index 000000000000..70f7d41728e8
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/FFY00/meson-python/
+"
+SRC_URI="
+ https://github.com/FFY00/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.60.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+"
+BDEPEND="
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest