summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-12-07 17:09:34 -0500
committerIan Stakenvicius <axs@gentoo.org>2018-12-07 17:10:02 -0500
commite0229d32bc38fc7de79ae58ebfa4b69ea29d7b57 (patch)
tree1d3904799788120de7c1409473722641c8a4c3c9
parentdev-lang/mono: keyword ~arm (diff)
downloadgentoo-e0229d32bc38fc7de79ae58ebfa4b69ea29d7b57.tar.gz
gentoo-e0229d32bc38fc7de79ae58ebfa4b69ea29d7b57.tar.bz2
gentoo-e0229d32bc38fc7de79ae58ebfa4b69ea29d7b57.zip
mail-client/thunderbird-60.3.3-r1: fix gdata-provider
Fixed issue where gdata-provider extension (installed via USE=lightning) would not load due to manifest.json not yet being properly supported. Signed-off-by: Ian Stakenvicius <axs@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--mail-client/thunderbird/thunderbird-60.3.3-r1.ebuild (renamed from mail-client/thunderbird/thunderbird-60.3.3.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/mail-client/thunderbird/thunderbird-60.3.3.ebuild b/mail-client/thunderbird/thunderbird-60.3.3-r1.ebuild
index b50bc9259df9..c3d4b19cab2e 100644
--- a/mail-client/thunderbird/thunderbird-60.3.3.ebuild
+++ b/mail-client/thunderbird/thunderbird-60.3.3-r1.ebuild
@@ -528,6 +528,12 @@ src_install() {
emid='{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}'
mkdir -p "${T}/${emid}" || die
cp -RLp -t "${T}/${emid}" "${BUILD_OBJ_DIR}"/dist/xpi-stage/gdata-provider/* || die
+
+ # manifest.json does not allow the addon to load, put install.rdf in place
+ # note, version number needs to be set properly
+ cp -RLp -t "${T}/${emid}" "${WORKDIR}"/gdata-provider-${MOZ_LIGHTNING_GDATA_VER}/install.rdf
+ sed -i -e '/em:version/ s/>[^<]*</>4.1</' "${T}/${emid}"/install.rdf
+
insinto ${MOZILLA_FIVE_HOME}/extensions
doins -r "${T}/${emid}"
fi