summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-28 18:06:40 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-28 18:13:08 -0700
commite08033079026092e4aaf3bc2027015e0c92f1b76 (patch)
tree9e86e0bb436a1f184ae744ec4208cc6d66b8e68e
parentsys-auth/pambase-20150213-r2: amd64 stable, bug 658646 (diff)
downloadgentoo-e0803307.tar.gz
gentoo-e0803307.tar.bz2
gentoo-e0803307.zip
x11-apps/igt-gpu-tools: Rename and version bump to 1.23
Project is not Intel-specific anymore and changed its name to igt-gpu-tools for version 1.23. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--profiles/updates/4Q-20181
-rw-r--r--x11-apps/igt-gpu-tools/Manifest1
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild (renamed from x11-apps/intel-gpu-tools/intel-gpu-tools-9999.ebuild)6
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild54
-rw-r--r--x11-apps/igt-gpu-tools/metadata.xml (renamed from x11-apps/intel-gpu-tools/metadata.xml)0
-rw-r--r--x11-apps/intel-gpu-tools/Manifest1
-rw-r--r--x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.22-KBL-ICL-PCI-IDs.patch53
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.22.ebuild90
8 files changed, 59 insertions, 147 deletions
diff --git a/profiles/updates/4Q-2018 b/profiles/updates/4Q-2018
index 5510200255e4..6e3e02489a62 100644
--- a/profiles/updates/4Q-2018
+++ b/profiles/updates/4Q-2018
@@ -2,3 +2,4 @@ slotmove dev-libs/girara 3 0
move dev-python/CommonMark dev-python/commonmark
move dev-libs/mini-xml dev-libs/mxml
move x11-misc/xembedsniproxy kde-plasma/xembed-sni-proxy
+move x11-apps/intel-gpu-tools x11-apps/igt-gpu-tools
diff --git a/x11-apps/igt-gpu-tools/Manifest b/x11-apps/igt-gpu-tools/Manifest
new file mode 100644
index 000000000000..f9704cb90276
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/Manifest
@@ -0,0 +1 @@
+DIST igt-gpu-tools-1.23.tar.xz 1045716 BLAKE2B f5e55ce9b682f2a9f2c6ab73c1e8e933ebea09b343f3af02df50b5bdce3e2ac313b1f92709c6de0d9fc7ffe2e2c9dfa95d2918ae9bd561cc285cff30fe59c6fd SHA512 8697265a978359e28983f483bf95819844597fc2080923d15d0587f6d648081af27e8ea318873e20103bbf8446b9f1005c6bc90a6276d3169837abd181f96839
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
index dcf138f5a867..65bdd0b60689 100644
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-9999.ebuild
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/app/${PN}.git"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
if [[ ${PV} = *9999* ]]; then
GIT_ECLASS="git-r3"
fi
@@ -11,7 +11,7 @@ inherit ${GIT_ECLASS} meson
DESCRIPTION="Intel GPU userland tools"
-HOMEPAGE="https://01.org/linuxgraphics https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/"
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
else
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
new file mode 100644
index 000000000000..65bdd0b60689
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa chamelium doc glib gsl sound valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xrandr xv"
+REQUIRED_USE="chamelium? ( glib gsl )"
+RESTRICT="test"
+
+X86_RDEPEND="
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ )"
+X86_DEPEND="x11-base/xorg-proto
+ >=dev-util/peg-0.1.18"
+RDEPEND="sys-apps/kmod:=
+ sys-libs/libunwind:=
+ sys-process/procps:=
+ virtual/libudev:=
+ >=x11-libs/cairo-1.12.0[X?]
+ >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ alsa? ( media-libs/alsa-lib:= )
+ chamelium? ( dev-libs/xmlrpc-c )
+ glib? ( dev-libs/glib:2 )
+ gsl? ( sci-libs/gsl )
+ valgrind? ( dev-util/valgrind )
+ video_cards_intel? ( sys-libs/zlib:= )
+ xrandr? ( >=x11-libs/libXrandr-1.3 )
+ amd64? ( ${X86_RDEPEND} )
+ x86? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ amd64? ( ${X86_DEPEND} )
+ x86? ( ${X86_DEPEND} )
+ doc? ( >=dev-util/gtk-doc-1.25-r1 )"
diff --git a/x11-apps/intel-gpu-tools/metadata.xml b/x11-apps/igt-gpu-tools/metadata.xml
index 511e4111b43c..511e4111b43c 100644
--- a/x11-apps/intel-gpu-tools/metadata.xml
+++ b/x11-apps/igt-gpu-tools/metadata.xml
diff --git a/x11-apps/intel-gpu-tools/Manifest b/x11-apps/intel-gpu-tools/Manifest
deleted file mode 100644
index 28006c423b50..000000000000
--- a/x11-apps/intel-gpu-tools/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST intel-gpu-tools-1.22.tar.xz 1022396 BLAKE2B c84338f3f84fcbe21a5b918b1afcc47d5419bd37828054fc3fa128d346b0f1b633d42f842464d96b28d4430788bfa9945a7596c14e6a79f8183440d3b9329c92 SHA512 af7964a3782bbc335c50c1c9c42f090306932423e76b9968d6919a2b633f3c11837e7ba572d352632c2b4db79bc98218d9d425c3b62e69abad5aa83d733dea8a
diff --git a/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.22-KBL-ICL-PCI-IDs.patch b/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.22-KBL-ICL-PCI-IDs.patch
deleted file mode 100644
index ff51969def4d..000000000000
--- a/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.22-KBL-ICL-PCI-IDs.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 0896b88d1b80244832f9eacbca993c5121315d05 Mon Sep 17 00:00:00 2001
-From: Paulo Zanoni <paulo.r.zanoni@intel.com>
-Date: Thu, 26 Apr 2018 17:49:41 -0700
-Subject: lib: sync with the newer i915_pciids.h from the Kernel (KBL + ICL)
-
-I just copied the Kernel file into the IGT repository.
-
-New IDs:
-- KBL GT2 sku from 672e314b21dc ("drm/i915/kbl: Add KBL GT2 sku")
-- ICL IDs from d55cb4fa2cf0 ("drm/i915/icl: Add the ICL PCI IDs")
-
-Cc: Matt Atwood <matthew.s.atwood@intel.com>
-Acked-by: Antonio Argenziano <antonio.argenziano@intel.com>
-Reviewed-by: Jose Roberto de Souza <jose.souza@intel.com>
-Signed-off-by: Paulo Zanoni <paulo.r.zanoni@intel.com>
----
- lib/i915_pciids.h | 13 +++++++++++++
- 1 file changed, 13 insertions(+)
-
-https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/patch/?id=0896b88d1b80244832f9eacbca993c5121315d05
-
-diff --git a/lib/i915_pciids.h b/lib/i915_pciids.h
-index 0b2ba46..bab70ff 100644
---- a/lib/i915_pciids.h
-+++ b/lib/i915_pciids.h
-@@ -349,6 +349,7 @@
- #define INTEL_KBL_GT2_IDS(info) \
- INTEL_VGA_DEVICE(0x5916, info), /* ULT GT2 */ \
- INTEL_VGA_DEVICE(0x5917, info), /* Mobile GT2 */ \
-+ INTEL_VGA_DEVICE(0x591C, info), /* ULX GT2 */ \
- INTEL_VGA_DEVICE(0x5921, info), /* ULT GT2F */ \
- INTEL_VGA_DEVICE(0x591E, info), /* ULX GT2 */ \
- INTEL_VGA_DEVICE(0x5912, info), /* DT GT2 */ \
-@@ -431,4 +432,16 @@
- INTEL_VGA_DEVICE(0x5A44, info), \
- INTEL_VGA_DEVICE(0x5A4C, info)
-
-+/* ICL */
-+#define INTEL_ICL_11_IDS(info) \
-+ INTEL_VGA_DEVICE(0x8A50, info), \
-+ INTEL_VGA_DEVICE(0x8A51, info), \
-+ INTEL_VGA_DEVICE(0x8A5C, info), \
-+ INTEL_VGA_DEVICE(0x8A5D, info), \
-+ INTEL_VGA_DEVICE(0x8A52, info), \
-+ INTEL_VGA_DEVICE(0x8A5A, info), \
-+ INTEL_VGA_DEVICE(0x8A5B, info), \
-+ INTEL_VGA_DEVICE(0x8A71, info), \
-+ INTEL_VGA_DEVICE(0x8A70, info)
-+
- #endif /* _I915_PCIIDS_H */
---
-cgit v1.1
-
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.22.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.22.ebuild
deleted file mode 100644
index 805a51f63791..000000000000
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.22.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-XORG_EAUTORECONF="yes"
-
-inherit xorg-2
-
-DESCRIPTION="Intel GPU userland tools"
-
-HOMEPAGE="https://01.org/linuxgraphics https://cgit.freedesktop.org/xorg/app/intel-gpu-tools/"
-SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
-KEYWORDS="~amd64 ~x86"
-LICENSE="MIT"
-SLOT="0"
-IUSE="alsa chamelium doc glib gsl sound test-programs valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xrandr xv"
-REQUIRED_USE="
- test-programs? ( sound? ( alsa gsl ) )
- chamelium? ( glib gsl )"
-RESTRICT="test"
-
-X86_RDEPEND="
- xv? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXv
- )"
-X86_DEPEND="x11-base/xorg-proto
- >=dev-util/peg-0.1.18"
-RDEPEND="sys-apps/kmod:=
- sys-libs/libunwind:=
- sys-process/procps:=
- virtual/libudev:=
- >=x11-libs/cairo-1.12.0[X?]
- >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
- >=x11-libs/libpciaccess-0.10
- alsa? ( media-libs/alsa-lib:= )
- chamelium? ( dev-libs/xmlrpc-c )
- glib? ( dev-libs/glib:2 )
- gsl? ( sci-libs/gsl )
- valgrind? ( dev-util/valgrind )
- video_cards_intel? ( sys-libs/zlib:= )
- xrandr? ( >=x11-libs/libXrandr-1.3 )
- amd64? ( ${X86_RDEPEND} )
- x86? ( ${X86_RDEPEND} )"
-DEPEND="${RDEPEND}
- amd64? ( ${X86_DEPEND} )
- x86? ( ${X86_DEPEND} )
- >=dev-util/gtk-doc-1.25-r1"
-
-PATCHES=(
- "${FILESDIR}"/${P}-KBL-ICL-PCI-IDs.patch
-)
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- $(usex test-programs $(use_enable sound audio) --disable-audio)
- $(use_enable chamelium)
- $(use_enable doc gtk-doc)
- $(use_enable test-programs tests)
- $(use_enable video_cards_amdgpu amdgpu)
- $(use_enable video_cards_intel intel)
- $(use_enable video_cards_nouveau nouveau)
- )
- xorg-2_src_configure
-}
-
-src_install() {
- xorg-2_src_install
- if use test-programs; then
- local testprogram
- pushd "${AUTOTOOLS_BUILD_DIR}"/tests >/dev/null || die
- for testprogram in $(<multi-tests.txt) $(<single-tests.txt); do
- if [[ -f ${testprogram} ]]; then
- dobin "${testprogram}"
- fi
- done
- popd >/dev/null
- fi
-}
-
-pkg_postinst() {
- xorg-2_pkg_postinst
- if use test-programs; then
- elog "Test programs for DRM driver development were installed. These are not"
- elog "designed to run outside their source tree, so may or may not work as"
- elog "intended."
- fi
-}