summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-04-12 18:56:28 +0200
committerAmy Liffey <amynka@gentoo.org>2017-04-12 18:59:15 +0200
commite100d4676d821df59fe477088a28b1775c003149 (patch)
tree3c33691d080e64168854c930ca166f491de2568f
parentdev-util/cmocka: Remove 1.1.0 (diff)
downloadgentoo-e100d4676d821df59fe477088a28b1775c003149.tar.gz
gentoo-e100d4676d821df59fe477088a28b1775c003149.tar.bz2
gentoo-e100d4676d821df59fe477088a28b1775c003149.zip
app-crypt/eid-mw: version bump 4.2.5. Vincent Hardy
Package-Manager: portage-2.3.3
-rw-r--r--app-crypt/eid-mw/Manifest1
-rw-r--r--app-crypt/eid-mw/eid-mw-4.2.5.ebuild98
-rw-r--r--app-crypt/eid-mw/files/gtk_not_required_4_2_5.patch75
-rw-r--r--app-crypt/eid-mw/metadata.xml2
4 files changed, 175 insertions, 1 deletions
diff --git a/app-crypt/eid-mw/Manifest b/app-crypt/eid-mw/Manifest
index d6c050028fb3..881a3d0dc699 100644
--- a/app-crypt/eid-mw/Manifest
+++ b/app-crypt/eid-mw/Manifest
@@ -1 +1,2 @@
DIST eid-mw-4.2.0.tar.gz 8508064 SHA256 4d86f4750f973a8dcf700544b92ffc3069a85ff93086538b9f334d76dd5c9747 SHA512 c0785e25c8b3640d0b60110553a520df3c3c5a0774f4f3fba6a4d9329c0d6e6187b0837d8c254a3959ffa798dc6299399e6cb8edfc7a20dabca080b61f532a5f WHIRLPOOL b1dee0c0a1800b81a7f392bc0e13d070a1cbc7fa6eb2f26e9c50903e058f322ff0b2da69469f90bd38240f49520be29bb548ca6954bc052ef5b23bdb4cad2643
+DIST eid-mw-4.2.5.tar.gz 7751526 SHA256 d2c46a65026790485f39db0b6d9b66a65b1d19061f3682a0b6da2e2b0c54bc81 SHA512 cf00f6aa295c3d057e77faddde31ba6b00ce44402bc0ad141c773fb58067d7cf2e107fc5f3a294be8731de592cb0895537cd29ad4e69f6721e6c77fa99c12075 WHIRLPOOL c24186b1f2b6b02df4a790e3a8c3d1f8e762b1e556d8f55aeeb4523a71387045827b47444246334933fc3d746485ea14086cfe41c5ec23f43826e6a7375c7fc3
diff --git a/app-crypt/eid-mw/eid-mw-4.2.5.ebuild b/app-crypt/eid-mw/eid-mw-4.2.5.ebuild
new file mode 100644
index 000000000000..f77817c88b4f
--- /dev/null
+++ b/app-crypt/eid-mw/eid-mw-4.2.5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools mozextension
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Fedict/${PN}.git
+ https://github.com/Fedict/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} ->
+ ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64 ~arm"
+fi
+
+SLOT="0"
+LICENSE="LGPL-3"
+DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government"
+
+HOMEPAGE="https://eid.belgium.be"
+
+IUSE="+dialogs +gtk p11-kit +xpi"
+
+REQUIRED_USE="
+ dialogs? ( gtk )"
+
+RDEPEND="gtk? (
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:*
+ dev-libs/libxml2
+ net-misc/curl[ssl]
+ net-libs/libproxy
+ !app-misc/eid-viewer-bin
+ )
+ >=sys-apps/pcsc-lite-1.2.9
+ p11-kit? ( app-crypt/p11-kit )
+ xpi? ( || ( >=www-client/firefox-bin-3.6.24
+ >=www-client/firefox-3.6.20 ) )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
+ sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
+
+ # hardcoded lsb_info
+ sed -i \
+ -e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \
+ -e "s:get_lsb_info('r'):strdup(_(\"n/a\")):" \
+ -e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \
+ plugins_tools/aboutmw/gtk/about-main.c || die
+
+ if [[ ${PV} == "9999" ]] ; then
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_9999.patch
+ else
+ use gtk || eapply "${FILESDIR}"/gtk_not_required_4_2_5.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable dialogs) \
+ $(use_enable p11-kit p11kit) \
+ --with-gnu-ld \
+ --disable-static \
+ --disable-signed
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use xpi; then
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/firefox-3.6.20'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ if has_version '>=www-client/firefox-bin-3.6.24'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+ fi
+ fi
+ rm -r "${D}/usr/share/mozilla" "${D}"/usr/$(get_libdir)/*.la || die
+ use gtk || rm -r "${D}/usr/include/eid-util" || die
+}
+
+pkg_postinst()
+{
+ use gtk && glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
diff --git a/app-crypt/eid-mw/files/gtk_not_required_4_2_5.patch b/app-crypt/eid-mw/files/gtk_not_required_4_2_5.patch
new file mode 100644
index 000000000000..a1680c2353d0
--- /dev/null
+++ b/app-crypt/eid-mw/files/gtk_not_required_4_2_5.patch
@@ -0,0 +1,75 @@
+diff --git a/Makefile.am b/Makefile.am
+index 393ecb3..0e14661 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ ACLOCAL_AMFLAGS = -I scripts/m4
+ EXTRA_DIST = scripts/build-aux/config.rpath scripts/build-aux/genver.sh .version debian rpm doc
+
+-SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 plugins_tools/util tests/unit plugins_tools/xpi plugins_tools/aboutmw/gtk plugins_tools/eid-viewer
++SUBDIRS=cardcomm/pkcs11/src doc/sdk/include/rsaref220 plugins_tools/util tests/unit plugins_tools/xpi
+
+ xpipackage:
+ $(MAKE) -C plugins_tools/xpi xpipackage
+diff --git a/cardcomm/pkcs11/src/Makefile.am b/cardcomm/pkcs11/src/Makefile.am
+index 02e4e36..86d607b 100644
+--- a/cardcomm/pkcs11/src/Makefile.am
++++ b/cardcomm/pkcs11/src/Makefile.am
+@@ -165,7 +165,6 @@ libbeidpkcs11_la_SOURCES += \
+ dialogs/dialogsgtk/single_dialog.c
+ endif
+
+-libexec_PROGRAMS = beid-askpin beid-changepin beid-badpin beid-askaccess beid-spr-askpin beid-spr-changepin
+
+ if P11KIT
+ dist_p11kitcf_DATA = beid.module
+@@ -176,30 +175,4 @@ install-exec-hook:
+ $(LN_S) $(libdir)/libbeidpkcs11.so.0 beidpkcs11.so
+ endif
+
+-beid_askpin_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-askpin.c
+-beid_askpin_CPPFLAGS = -I$(srcdir)/dialogsgtk -I$(srcdir)/../common/src -I$(srcdir)/src @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_askpin_LDADD = @GTK_LIBS@
+-
+-beid_changepin_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-changepin.c
+-beid_changepin_CPPFLAGS = -I$(dialogsdir)/dialogsgtk -I$(dialogsdir)/../common/dialogs -I$(dialogsdir)/dialogs @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_changepin_LDADD = @GTK_LIBS@
+-
+-beid_badpin_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-badpin.c
+-beid_badpin_CPPFLAGS = -I$(dialogsdir)/dialogsgtk -I$(dialogsdir)/../common/dialogs -I$(dialogsdir)/dialogs @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_badpin_LDADD = @GTK_LIBS@
+-
+-beid_askaccess_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-askaccess.c
+-beid_askaccess_CPPFLAGS = -I$(dialogsdir)/dialogsgtk -I$(dialogsdir)/../common/dialogs -I$(dialogsdir)/dialogs @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_askaccess_LDADD = @GTK_LIBS@
+-
+-beid_spr_askpin_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-spr-askpin.c
+-beid_spr_askpin_CPPFLAGS = -I$(dialogsdir)/dialogsgtk -I$(dialogsdir)/../common/dialogs -I$(dialogsdir)/dialogs @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_spr_askpin_LDADD = @GTK_LIBS@
+-
+-beid_spr_changepin_SOURCES = dialogs/dialogsgtk/parent.c dialogs/dialogsgtk/beid-spr-changepin.c
+-beid_spr_changepin_CPPFLAGS = -I$(dialogsdir)/dialogsgtk -I$(dialogsdir)/../common/dialogs -I$(dialogsdir)/dialogs @GTK_CFLAGS@ -DDATAROOTDIR='"$(datarootdir)"'
+-beid_spr_changepin_LDADD = @GTK_LIBS@
+-
+ pkgconfig_DATA=libbeidpkcs11.pc
+-
+-SUBDIRS = dialogs/dialogsgtk/po
+diff --git a/configure.ac b/configure.ac
+index 9bf10f9..f0120b1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -59,14 +59,6 @@ fi
+
+ AC_DEFINE_UNQUOTED([HAVE_GTK], [$have_gtk], [Set to major version of libgtk])
+
+-if test "$have_gtk" = "no"
+-then
+- AC_MSG_ERROR([At least one version of GTK is required.])
+-fi
+-
+-PKG_CHECK_MODULES([XML2], [libxml-2.0])
+-PKG_CHECK_MODULES([libproxy], [libproxy-1.0])
+-
+ ###########################################################################
+ ####### read user-specific requests from --enable directives ######
+ ###########################################################################
diff --git a/app-crypt/eid-mw/metadata.xml b/app-crypt/eid-mw/metadata.xml
index 9cc32049c190..5a0c5666c030 100644
--- a/app-crypt/eid-mw/metadata.xml
+++ b/app-crypt/eid-mw/metadata.xml
@@ -16,7 +16,7 @@ With your eID, you can:
- authenticate yourself. This is a way of checking that you are who you say you are. That can be handy on the internet or to enable your children to chat in safety.
- place a legally binding electronic signature on electronic documents.
-These three functions form the basis of the countless applications for your eID. Go to http://welcome-to-e-belgium.be/en/ and check out what can you do with it? and discover all the things you can use the eID for.
+These three functions form the basis of the countless applications for your eID. Go to https://my.belgium.be and check out what can you do with it? and discover all the things you can use the eID for.
</longdescription>
<use>
<flag name="gtk">