summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-01 00:45:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-01 00:45:36 +0100
commite1105fb37a4f5f686f67e0eec675fd437253a3c4 (patch)
treeef93665782fd3198c164e36e202cf1b77f12f42f
parentgames-board/pychess: amd64 stable wrt bug #602142 (diff)
downloadgentoo-e1105fb37a4f5f686f67e0eec675fd437253a3c4.tar.gz
gentoo-e1105fb37a4f5f686f67e0eec675fd437253a3c4.tar.bz2
gentoo-e1105fb37a4f5f686f67e0eec675fd437253a3c4.zip
sys-devel/m4: Bump to version 1.4.18
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sys-devel/m4/Manifest1
-rw-r--r--sys-devel/m4/m4-1.4.18.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/m4/Manifest b/sys-devel/m4/Manifest
index a2caf523c174..6259ce1ca426 100644
--- a/sys-devel/m4/Manifest
+++ b/sys-devel/m4/Manifest
@@ -1,2 +1,3 @@
DIST m4-1.4.16.tar.xz 1005264 SHA256 d5b5d51cf8f5b18f3bac39bc2f6b1e61f34d400136ae1a87d075e26a38028d5d SHA512 1123671ab3e0b1b13a4a08035e792a93af0d7d0a5b9027982fe7b5104488a0746906068a0f4774c1f1bc2648ba1bc74d690836e90ff9391464278e4ccbc7edf0 WHIRLPOOL 0438098dab71f6a66c2b18aed2941ef9a2152a8061c2f9903373a1348b261354429806c2bd313f55c7aaa612fe4c2f7628a1fff3c80819565df2a3b664485c23
DIST m4-1.4.17.tar.xz 1149088 SHA256 f0543c3beb51fa6b3337d8025331591e0e18d8ec2886ed391f1aade43477d508 SHA512 406e6e97c3f5c5f3c8055bac748d4fe8c2e861d97e84ab6d840a2caa7df04f523cc662d6d51f6afae7d6c219d03693c7ae0c1e669a80246a3ceb5e8342b82389 WHIRLPOOL 69a9f9129dd2f2fd0f5d61771cbac2208f10aa83e0d42fe4213eb10283cc68ce1a96717aece99e92890a4135eb7e201c638d4d9bc17ac10026b0989f3a64940e
+DIST m4-1.4.18.tar.xz 1207688 SHA256 f2c1e86ca0a404ff281631bdc8377638992744b175afb806e25871a24a934e07 SHA512 06f583efc3855cd8477d8347544f4ae5153a3e50aea74d21968afa7214784ea3ddfc02d0a2b11324120d76a19f2e804d20de11a456b5da929eb6ae469519b174 WHIRLPOOL bed79746e774e17c8487e0e1c02e62d961dfcdeb3ed0852fb948b77b5baf7b7d35bcf69d6d0d01ff5e8f873fffd0dadc92ebdfcf31bf87ac302e3cfb0e6ce497
diff --git a/sys-devel/m4/m4-1.4.18.ebuild b/sys-devel/m4/m4-1.4.18.ebuild
new file mode 100644
index 000000000000..8e992f6c100d
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+# remember: cannot dep on autoconf since it needs us
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+src_configure() {
+ # Disable automagic dependency over libsigsegv; see bug #278026
+ export ac_cv_libsigsegv=no
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf --enable-changeword ${myconf}
+}
+
+src_test() {
+ [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
+ emake check
+}
+
+src_install() {
+ default
+ # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
+ # gm4, it might find gm4 from outside the prefix on for instance Darwin
+ use prefix && dosym /usr/bin/m4 /usr/bin/gm4
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}