summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 05:39:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:07:26 +0200
commite186137a5ce4250fc6f7deb505ac7d2273d7bf88 (patch)
tree74b9b1cecb71b71f299ebb1708c8a191bb717a8d
parentnet-misc/electrum: Bump to 4.4.4 (diff)
downloadgentoo-e186137a5ce4250fc6f7deb505ac7d2273d7bf88.tar.gz
gentoo-e186137a5ce4250fc6f7deb505ac7d2273d7bf88.tar.bz2
gentoo-e186137a5ce4250fc6f7deb505ac7d2273d7bf88.zip
dev-python/ruamel-yaml: Bump to 0.17.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.31.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 5998a842e753..9260adac1fcd 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -5,3 +5,4 @@ DIST ruamel.yaml-0.17.24.tar.xz 186504 BLAKE2B d5bd5240c3ad68309ad9382dd076111f5
DIST ruamel.yaml-0.17.26.tar.xz 186752 BLAKE2B ce3d914ac27df2d038a882535f3559b47051a1fb1206a3ab6cab7c2ee0ee9fcfb5fc0babfb3a3488e7d074798bcbdb24d67d2a37a00c9d9210e96f13bb5bcdbb SHA512 40a91002f904621632acaa73b5bd3095f933369d354a8e7579a5afe4c171ceefadb76d5ecbdd3ef6202833874ba19ed518ce5ac5c7dbf15b698dd07b95260d33
DIST ruamel.yaml-0.17.28.tar.xz 187800 BLAKE2B 24dbf1c3fc76ec2f6255a7771dfa3bae24bf97c7014bd3205dd4968d73bdd9c4fc9e3adf721dba89c50554d13dbdd528f5f67c99692ef15b361119330b35005e SHA512 313bd7e4cfa559f90e150cf5a522b5c690b680b38df24ea3b4320484012b6e4c841f94fd21ca33283dfc0a1d04c465d38d4b5d48f95d2f1f9b876dc371a74f35
DIST ruamel.yaml-0.17.30.tar.xz 189936 BLAKE2B 9e662551527372b3a1654d8e5da8c1e0a22f432d6564a807fe89bee7f93e2878d47e6a97f50475643575e89eb03564beb86daa7295d14513ff09615d38441f3b SHA512 0e460fa05e69d99591ff4dd1b35ae3be4ba40f21bcf514f16256a56a346b570c7c41a56e1ccf7c1d3ff14beb53800a4f0752243aa20fc37df345509c293d351a
+DIST ruamel.yaml-0.17.31.tar.xz 190068 BLAKE2B cb5682ca184d86f8acb2516f0ce515deb81f3eb1bd9ea0b340c588e738f657076d589424e71492cf8fe37f5a2f62e0c9881644770c23ef1cb8a6d42cae48a86c SHA512 5a453a31babe1b9ad3b782ae06598f5f65d5e6aee167beaf7b898a2b624578245915ef0579bb7f9eefbecee28a472d6f3e04cc721b0c7b320e79f5986225986c
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.31.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.31.ebuild
new file mode 100644
index 000000000000..171e0b89375a
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.31.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}