summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 00:15:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 00:29:40 +0200
commite1a72f255fc748f0827d978771fc1fc6a77a45e4 (patch)
tree32d293b4d4596b080350b1e555b488c9d42cafd8
parentdev-python/botocore: Bump to 1.20.107 (diff)
downloadgentoo-e1a72f25.tar.gz
gentoo-e1a72f25.tar.bz2
gentoo-e1a72f25.zip
dev-python/boto3: Bump to 1.17.107
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.107.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e13cb7670c03..8f52864c0e11 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,4 +1,5 @@
DIST boto3-1.17.104.tar.gz 387800 BLAKE2B 928824ab0a0c091fec430c5d86b0c5663f2a98042a76311588463f36f48a6bd9641fd25e07b63ad50afcb3ea9bfea0b5f3304e3c2689a2187198aac04549346c SHA512 477033e623476fa1e2e49cdb788f204ac49230088788cbae3f079de4561e7bbe56bb3b170480592a0ce056fcd2ea0cb3f14b4f5091279f46346465853a191829
DIST boto3-1.17.105.tar.gz 387920 BLAKE2B 475342a93440418f6fc5682e7c24f386aaac8dc91e670e8c6ab7f949fb8557c97ca0f7e7929128742c3b1091cda2a42e0f1212528f8fb1c7ce1a6dcc3aea18c4 SHA512 a044f0a61f8ebea58f7ebbe670b4f0ba94f6c3abe69857340908be780e1cae5f5f3ce892ba16af44df62542883d30b93a9b42830123dd3fb31998ae8c642e1b4
DIST boto3-1.17.106.tar.gz 388602 BLAKE2B f9cc023ce4c0810ea7eb004126941229536fc068ff51039dc9f9943d153f8fa717e832c7161f85332e3edf596f55b3ad7dfb9ef117b471f59fc269ee9c63818c SHA512 866286d91d157d513f35231f8d512cd9738c7795b044b41c8e2b1594ed83a6060bcb3a2e3c8388df2ed86c7b04e0ce2d42c88393d8a6753d04c2a007865033e4
+DIST boto3-1.17.107.tar.gz 389348 BLAKE2B 8c0893d8ad73563f63254877621440ba24dac76c577f5684bc37b5f99b9111be209f69efa324cc079209340051230a43b66004d09ccd5804d631b0c04083c384 SHA512 450222507aa3bae8062b788ac7f637dbe8a5e7a5baa0f45001a74a810c2579927a7400cef180b57a7d7e57c391d665930b577b39272681ca380b5e553385b1f8
DIST boto3-1.17.97.tar.gz 383223 BLAKE2B 1a1b4e9f2c51d830762f27cf3e30038efb88322e300ac304d1cb88d5b7efc6af35ad9810cea7292c9807dcdfedb11ba039ee6d5dbb9162f2a1c6d6936ef75bcc SHA512 e74a59763cc9b8a51fd09121a790d29a7291d9380d4451c2e6af90902f18415a3780eeea7f7d63e052b295792b92c3cdd3b8597f7013241ebbbdb7e418cf73ce
diff --git a/dev-python/boto3/boto3-1.17.107.ebuild b/dev-python/boto3/boto3-1.17.107.ebuild
new file mode 100644
index 000000000000..75afb4bcf865
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.107.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}