summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-03 10:54:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-03 18:10:48 +0100
commite1f86f521584a62ec3c0fcf5cc593b07725f197b (patch)
treebc3491b3f66c49ec833d28242046b403503e7a73
parentmedia-sound/elisa: 21.12.2 version bump (diff)
downloadgentoo-e1f86f521584a62ec3c0fcf5cc593b07725f197b.tar.gz
gentoo-e1f86f521584a62ec3c0fcf5cc593b07725f197b.tar.bz2
gentoo-e1f86f521584a62ec3c0fcf5cc593b07725f197b.zip
kde-apps/dolphin-plugins-dropbox: 21.12.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.12.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 2148b98ba9f0..95eadf9c5e25 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-21.08.3.tar.xz 254604 BLAKE2B 9a7a9c7a1cf82d458c1fd0bbce6b47c233b8a7a20bd1d1696bc75d6b04c8e4a9d6464025d8ad39b3bb96b8dd428fb880a5d318f7c0d13ef3bc8bf24a42c24169 SHA512 2fb7fbd6490d768f3eb7d756429d858337b8088a7c87836ed4a54fc3f863f50c4973bbe2ae149d53d2769d7ce3c31fbd737bc4afc74fd14260a158da83992076
DIST dolphin-plugins-21.12.1.tar.xz 254672 BLAKE2B ab30e233774bd4d1bcd2446e19180235ba04248cf636f2c3dbe8b0e0c4a5756a35fbde78f429d2daf03cff969d47023395958305c94b3ab05e614f1e004347f8 SHA512 4fc0eb757cc32a881c0f764a09acc7aa1b8be302b8b74608121151a3ddb4cd3a2b299c0eb1fe5d7dcdf702cc331dd2bbda986bef079f9110a6fb0b9274ce397b
+DIST dolphin-plugins-21.12.2.tar.xz 254836 BLAKE2B 1f8cdfc133a0c7e9083c8ab9fbd0e6dec5221ca89c5bff37d14aa6e4e286c0046512875f1d45544e11bde71f7cdd5d756996eea56e9dba29888dbfad821eb2aa SHA512 44e93558802282f3a73aaac9443dcded8498499c4ab400dedb68572af4add007dcbae6424a99929da6c5ab03c7c125beee313fe4b14b5ee29147938418410dfc
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.12.2.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.12.2.ebuild
new file mode 100644
index 000000000000..c754e50f14f9
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-21.12.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.88.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}