summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-06 07:37:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-06 08:59:10 +0100
commite31633e53e0f754e9fd53b3a56cd93934b34118f (patch)
treedcd8f96fe241d960daa1428dc655c7b4609dfb8d
parentdev-python/pip: Bump to 22.3.1 (diff)
downloadgentoo-e31633e53e0f754e9fd53b3a56cd93934b34118f.tar.gz
gentoo-e31633e53e0f754e9fd53b3a56cd93934b34118f.tar.bz2
gentoo-e31633e53e0f754e9fd53b3a56cd93934b34118f.zip
dev-python/ensurepip-pip: Bump to 22.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-pip/Manifest1
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-22.3.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ensurepip-pip/Manifest b/dev-python/ensurepip-pip/Manifest
index b4c2d0ef745d..f4d72484dcba 100644
--- a/dev-python/ensurepip-pip/Manifest
+++ b/dev-python/ensurepip-pip/Manifest
@@ -1,2 +1,3 @@
DIST pip-22.2.2-py3-none-any.whl 2044706 BLAKE2B 254427e593e44d9f1ce48276fd40f214e8ca9d27b6c31b7a6ed5fa4566df6b1f723215c6a1766a534ce18174f2363c383dbff19368d1b89f1519a53bebd34215 SHA512 142d3144c14b692c645613d98bf35dd91193128d5e21b61a8a702548f1247fac662499d6e39b65c0aa9a0444d2d92983fd8c410439796626485a4e1be99a102f
DIST pip-22.3-py3-none-any.whl 2051507 BLAKE2B e9822b6154aed421066a1cb173f08281ecb4769136607775d6d5f75a038613899b960fe3cd4f0356d8d6b2b891b64f54f69eff46a2875ddca49200c1e4e88222 SHA512 4e71295da5d1a26c71a0baa8905fdccb522bb16d56bc964db636de68688c5bf703f3b2880cdeea07138789e0eb4506e06f9ccd0da906c89d2cb6d55ad64659ea
+DIST pip-22.3.1-py3-none-any.whl 2051534 BLAKE2B b15f5eac6b3d8d12b382aabfb7fc920bea564be7f9133050d7cb0b4627a92c1de19676dced6bcb79971701898bb1606f3ea1b44349ab35527de90936c0057c71 SHA512 f09c2a48e85108514c20fdc58466b9be6a9b7f234241ccd46e23249f690bd1ec03fa5e60c9df80f4cf31a9be64d7d59b2fa786c1d7779e284fec42b04bffc257
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-22.3.1.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-22.3.1.ebuild
new file mode 100644
index 000000000000..27ee812d0240
--- /dev/null
+++ b/dev-python/ensurepip-pip/ensurepip-pip-22.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared pip wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/pip/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}