summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-12 08:34:47 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-13 07:53:32 -0400
commite3872654319f170aed70c9418c7d3d565fb0dd1e (patch)
tree2ca24c4ca1c7b5bf0e1a453254b85adce24f5f52
parentapp-metrics/prometheus: Version bump to 2.4.0 (diff)
downloadgentoo-e3872654319f170aed70c9418c7d3d565fb0dd1e.tar.gz
gentoo-e3872654319f170aed70c9418c7d3d565fb0dd1e.tar.bz2
gentoo-e3872654319f170aed70c9418c7d3d565fb0dd1e.zip
app-crypt/acme-tiny: bump to 4.0.4
Also, add myself as co-maintainer. Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--app-crypt/acme-tiny/Manifest1
-rw-r--r--app-crypt/acme-tiny/acme-tiny-4.0.4.ebuild48
-rw-r--r--app-crypt/acme-tiny/acme-tiny-9999.ebuild4
-rw-r--r--app-crypt/acme-tiny/metadata.xml4
4 files changed, 55 insertions, 2 deletions
diff --git a/app-crypt/acme-tiny/Manifest b/app-crypt/acme-tiny/Manifest
index 4bc5473e28cd..597e593eb039 100644
--- a/app-crypt/acme-tiny/Manifest
+++ b/app-crypt/acme-tiny/Manifest
@@ -1 +1,2 @@
DIST acme-tiny-4.0.3.tar.gz 12662 BLAKE2B 6a17d0597731a5c8c1b260fa47396cb5bf8a223f44c8e498532b6e90a2ded35c5fcae058a8682e59ab060c1eeb27e09c8db8588e1d72cfd75b65f867d3e94f9a SHA512 bd37d4f878f2851c8e88acb78699b855cfd306928e2d70ef1d35dc9883d44dae3c7622e2114b1d5c4e0c5865b61ad3958a776467ab45eaedb0cf612530ca5dc7
+DIST acme-tiny-4.0.4.tar.gz 12667 BLAKE2B 6177d639a2d65080f84ca93400405c01ef18cb3c8d18ef5e7e57af1eede9d6f1e105ca7f6f89014e79c5cb1d865d3c81f590abdb37e8caa6b9699ea20064f698 SHA512 e66befe8262b3396e5e55ea01fc47c668c527868832d2ccdc2786156ec52e698fd20cb6fa4fe861d97947d64f4b6c751be9c79bf546eaac34978c53b9e6f85e4
diff --git a/app-crypt/acme-tiny/acme-tiny-4.0.4.ebuild b/app-crypt/acme-tiny/acme-tiny-4.0.4.ebuild
new file mode 100644
index 000000000000..184d1bfb35b9
--- /dev/null
+++ b/app-crypt/acme-tiny/acme-tiny-4.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
+HOMEPAGE="https://github.com/diafygi/acme-tiny"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0"
+
+pkg_setup() {
+ if [[ ${PV} != 9999 ]]; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ fi
+}
+
+src_prepare() {
+ sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
+ einfo "The --account-email flag has been changed to --contact and"
+ einfo "has different syntax."
+ einfo "Please update your scripts accordingly"
+ fi
+ done
+}
diff --git a/app-crypt/acme-tiny/acme-tiny-9999.ebuild b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
index b9815c348094..184d1bfb35b9 100644
--- a/app-crypt/acme-tiny/acme-tiny-9999.ebuild
+++ b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit distutils-r1 eapi7-ver
+inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
inherit git-r3
diff --git a/app-crypt/acme-tiny/metadata.xml b/app-crypt/acme-tiny/metadata.xml
index 1e492cbeec20..b009e2c6b3e2 100644
--- a/app-crypt/acme-tiny/metadata.xml
+++ b/app-crypt/acme-tiny/metadata.xml
@@ -5,6 +5,10 @@
<email>NP-Hardass@gentoo.org</email>
<name>NP-Hardass</name>
</maintainer>
+ <maintainer type="person">
+ <email>vdupras@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
<longdescription>
A tiny, auditable script for Let's Encrypt's ACME Protocol
</longdescription>