summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-29 10:39:35 +0100
committerSam James <sam@gentoo.org>2022-04-29 11:20:36 +0100
commite389113bbd40594a7780dfc79807f8eea4765e50 (patch)
tree9dc13cad366ea3dab464b9b9b971923b4fd7e40c
parentapp-dicts/verbiste: drop 0.1.44 (diff)
downloadgentoo-e389113bbd40594a7780dfc79807f8eea4765e50.tar.gz
gentoo-e389113bbd40594a7780dfc79807f8eea4765e50.tar.bz2
gentoo-e389113bbd40594a7780dfc79807f8eea4765e50.zip
app-emulation/guestfs-tools: drop 1.46.1-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/guestfs-tools/Manifest1
-rw-r--r--app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild150
2 files changed, 0 insertions, 151 deletions
diff --git a/app-emulation/guestfs-tools/Manifest b/app-emulation/guestfs-tools/Manifest
index 4547aa0ebc0b..5626fdc34c99 100644
--- a/app-emulation/guestfs-tools/Manifest
+++ b/app-emulation/guestfs-tools/Manifest
@@ -1,2 +1 @@
-DIST guestfs-tools-1.46.1.tar.gz 12665804 BLAKE2B 7800954dfa961900035b127f6ac2556f584dd2d156143bf82fd1ba9fd1f327091706987192d91cb4251295d9565e56f769ab06bdac677160ac31d2e8f9d9a488 SHA512 d2bd0790343d54a2517237e56d1b982cd41335654fd205cfeec42a1b7cbbf4c0923597b767b8769dfe74766e078a817d520db251895990b922522030806d0b85
DIST guestfs-tools-1.48.0.tar.gz 12682919 BLAKE2B 27b4e5c47af222691b067c19e997112acaf0360cc9c089dedb0327959ff8d80ff929e2fea369f9895ed6e1fc80a339ca89db3b9eb32cf23328fc71972447a13e SHA512 8576ef0e283a02a112f785e8f1656b41c93be29e12617ee8c83033b90758736ea3c2d4ecfb446a86c7913e2c0b39a7c5666e8ad22682419cc877543a3825c489
diff --git a/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild b/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild
deleted file mode 100644
index ed65ee9489f6..000000000000
--- a/app-emulation/guestfs-tools/guestfs-tools-1.46.1-r1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic linux-info perl-functions strip-linguas toolchain-funcs
-
-MY_PV_1="$(ver_cut 1-2)"
-MY_PV_2="$(ver_cut 2)"
-[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
-
-DESCRIPTION="Tools for accessing, inspecting, and modifying virtual machine (VM) disk images"
-HOMEPAGE="https://libguestfs.org/"
-SRC_URI="https://download.libguestfs.org/${PN}/${MY_PV_1}-${SD}/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0/${MY_PV_1}"
-KEYWORDS="~amd64"
-IUSE="doc +ocaml +perl test"
-RESTRICT="!test? ( test )"
-
-# Failures - doc
-COMMON_DEPEND="
- !<app-emulation/libguestfs-1.46.0-r1
- app-arch/cpio
- app-arch/lzma
- app-arch/unzip[natspec]
- app-arch/xz-utils
- app-crypt/gnupg
- >=app-emulation/libguestfs-${MY_PV_1}:=[ocaml?,perl?]
- app-emulation/libvirt:=
- >=app-emulation/qemu-2.0[qemu_softmmu_targets_x86_64,filecaps]
- dev-lang/perl:=
- dev-libs/libpcre2:=
- dev-libs/libxml2:2
- dev-libs/jansson:=
- >=sys-apps/fakechroot-2.8
- sys-fs/squashfs-tools:*
- sys-libs/libxcrypt:=
- virtual/libcrypt:=
- ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
- perl? (
- virtual/perl-Data-Dumper
- virtual/perl-Getopt-Long
- dev-perl/Module-Build
- dev-perl/libintl-perl
- virtual/perl-ExtUtils-MakeMaker
- >=dev-perl/Sys-Virt-0.2.4
- dev-perl/String-ShellQuote
- test? ( virtual/perl-Test-Simple )
- )
-"
-# Some OCaml is always required
-# bug #729674
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/ocaml-4.03:=[ocamlopt]
- dev-ml/findlib[ocamlopt]
- doc? ( app-text/po4a )
- ocaml? (
- dev-ml/ounit2[ocamlopt]
- || (
- <dev-ml/ocaml-gettext-0.4.2
- dev-ml/ocaml-gettext-stub[ocamlopt]
- )
- )
-"
-BDEPEND="virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- app-emulation/libguestfs-appliance
-"
-
-DOCS=( AUTHORS BUGS ChangeLog HACKING README TODO )
-
-#PATCHES=(
-# "${FILESDIR}"/${MY_PV_1}/
-#)
-
-pkg_setup() {
- CONFIG_CHECK="~KVM ~VIRTIO"
- [[ -n "${CONFIG_CHECK}" ]] && check_extra_config
-}
-
-src_configure() {
- # bug #794877
- tc-export AR
-
- if use test ; then
- # Skip Bash test
- # (See 13-test-suite.log in linked bug)
- # bug #794874
- export SKIP_TEST_COMPLETE_IN_SCRIPT_SH=1
-
- # This test requires libvirt support in libguestfs and it makes
- # no difference at runtime. Just gracefully skip it to make life
- # easier for e.g. arch testing.
- if ! has_version 'app-emulation/libguestfs[libvirt]' ; then
- export SKIP_TEST_VIRT_ALIGNMENT_SCAN_GUESTS_SH=1
- fi
-
- # Needed for the inspector tests. Provided by libguestfs-appliance.
- #export LIBGUESTFS_PATH="${BROOT}"/usr/share/guestfs/appliance/
- # But the inspector tests seem fragile anyway...
- export SKIP_TEST_VIRT_INSPECTOR_LUKS_SH=1
- export SKIP_TEST_VIRT_INSPECTOR_SH=1
- fi
-
- # Disable feature test for kvm for more reason
- # i.e: not loaded module in __build__ time,
- # build server not supported kvm, etc. ...
- #
- # In fact, this feature is virtio support and requires
- # configured kernel.
- export vmchannel_test=no
-
- # Give a nudge to help find libxcrypt[-system]
- # We have a := dep on virtual/libcrypt to ensure this
- # doesn't become stale.
- # bug #703118, bug #789354
- if ! has_version 'sys-libs/libxcrypt[system]' ; then
- append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/xcrypt"
- append-ldflags "-Wl,-R${ESYSROOT}/usr/$(get_libdir)/xcrypt"
- fi
-
- econf \
- $(usex doc '' PO4A=no) \
- $(use_enable ocaml) \
- $(use_enable perl)
-}
-
-src_install() {
- strip-linguas -i po
-
- emake DESTDIR="${D}" install "LINGUAS=""${LINGUAS}"""
-
- find "${ED}" -name '*.la' -delete || die
-
- if use perl ; then
- perl_delete_localpod
- fi
-}
-
-pkg_postinst() {
- if ! use ocaml ; then
- einfo "OCaml based tools and bindings (virt-resize, virt-sparsify, virt-sysprep, ...) NOT installed"
- fi
-
- if ! use perl ; then
- einfo "Perl based tools NOT built"
- fi
-}