summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-31 22:05:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-03-31 22:30:05 +0200
commite392df817efea77c0776de780ea4bdbf03de6382 (patch)
tree6fd711581eac1e995c06a6e05b9b7b42f3f56961
parentmedia-plugins/alsa-plugins: Bump to version 1.1.1 (diff)
downloadgentoo-e392df817efea77c0776de780ea4bdbf03de6382.tar.gz
gentoo-e392df817efea77c0776de780ea4bdbf03de6382.tar.bz2
gentoo-e392df817efea77c0776de780ea4bdbf03de6382.zip
media-plugins/alsa-plugins: Removed old.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-plugins/alsa-plugins/Manifest2
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild92
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.27-r3.ebuild99
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.28.ebuild94
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-missing-avutil.patch11
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg-version-check.patch13
-rw-r--r--media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg.patch38
7 files changed, 0 insertions, 349 deletions
diff --git a/media-plugins/alsa-plugins/Manifest b/media-plugins/alsa-plugins/Manifest
index 700a00dfb3a1..007f533daff2 100644
--- a/media-plugins/alsa-plugins/Manifest
+++ b/media-plugins/alsa-plugins/Manifest
@@ -1,5 +1,3 @@
-DIST alsa-plugins-1.0.27.tar.bz2 363593 SHA256 0bbd0c37c2dd7baf16363afb2e58169ffb0f9c0a70031b3b6235594630f3ab35 SHA512 73c2010b66022429bc664bdab1c03694dfd669260dea569e32496bc6e10a11a0da2dd87db6a661ab1376f3aa59f1df8a84cb48ff1d20bb064756c655203f9993 WHIRLPOOL 4487734e0377c880a46df6f7fa53d86a7c38fa3d4bd35e06d128c0ec2b99c789ed64674b59003d8bd0abce2db53301234e467d235532ea145ddb150919cb49af
-DIST alsa-plugins-1.0.28.tar.bz2 366023 SHA256 426f8af1a07ee9d8c06449524d1f0bd59a06e0331a51aa3d59d343a7c6d03120 SHA512 c79cf22f426f500c704c947af602604c62a76a026c9b945589d1ca83dff16de23cec2f1c29c9713e42736092aa0d0389e514ca2ca646f8e4770c8aa8320725cc WHIRLPOOL 9cb54e2a30a3f682aa23acb6317f267ffb3cd47eceb959fbce73c8db3ba7c8af420b91b91cce865f0aaf0c60b2920f51972640aff8413c871d0709fa7f4f90a6
DIST alsa-plugins-1.0.29.tar.bz2 366077 SHA256 325d85cac285f632b83e0191ae3f348bad03c1f007b937042f164abb81ea6532 SHA512 6bc7d417ee5deb00a6e36864778deb4675a186951747cc799386288704f0d22a5c3d7011b6091602378d02ee79c4696ebb879140cebea392bd68937c8640898a WHIRLPOOL 987c348b536b03b36c2e7f9bff733e5309961b6f052d6a76f1372eb231d9af92191c113d0a577221809b0fcc4bc9614f278afb10472bd1606822aab468210af3
DIST alsa-plugins-1.1.0.tar.bz2 366296 SHA256 3b83c329953bef99f5fe25ae04ec4a455fe6514939f3b45a5321966652b2c9ee SHA512 5ed31ce1b6d11232d464d3cdef6015403840edbf2154266a479c2fde12ef4506e1f20c0f405ccee9cc39aec80be3bc41b10798a4475494ba56c6b4d69637fdc9 WHIRLPOOL 32c8460ed27a6a554f983e476e09847940e152cbc7b8cf0909243d312091560b1b25360249e3edeae50a46c5990f216cfd17915ec539812a5c473406705c2e73
DIST alsa-plugins-1.1.1.tar.bz2 366193 SHA256 8ea4d1e082c36528a896a2581e5eb62d4dc2683238e353050d0d624e65f901f1 SHA512 9dd277cb5cce144ce4e5e0010cebcba0f8634c783e7bcd80ce6d04b198d6de5150a2764df3087a39a468b5fb7c4578de2e252095568e811dedaa5e7ffdbeb7c9 WHIRLPOOL 20f36afcb01dfe47172b6470fea929ffb267e0b7a78ac4ca8c2031b33faa6fe15bd0608d9963e053366ac6bf3b2f540d776537c8547418a0d2b80b5c0366a76f
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild
deleted file mode 100644
index 32e81d4165e5..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils flag-o-matic multilib
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-linux"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-RDEPEND=">=media-libs/alsa-lib-${PV}:=
- ffmpeg? ( virtual/ffmpeg )
- jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
- libsamplerate? ( media-libs/libsamplerate:= )
- pulseaudio? ( media-sound/pulseaudio )
- speex? ( media-libs/speex:= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch \
- "${FILESDIR}"/${PN}-1.0.23-automagic.patch \
- "${FILESDIR}"/${P}-{ffmpeg,ffmpeg-version-check}.patch
-
- epatch_user
-
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i \
- -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- pulse/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- use debug || append-cppflags -DNDEBUG
-
- local myspeex=no
- use speex && myspeex=lib
-
- econf \
- $(use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- cd doc
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use ffmpeg && dodoc lavcrate.txt a52.txt
-
- if use pulseaudio; then
- dodoc README-pulse
- # install ALSA configuration files
- # making PA to be used by alsa clients
- insinto /usr/share/alsa
- doins "${FILESDIR}"/pulse-default.conf
- insinto /usr/share/alsa/alsa.conf.d
- doins "${FILESDIR}"/51-pulseaudio-probe.conf
- # bug #410261, comment 5+
- # seems to work fine without any path
- sed -i \
- -e "s:/usr/lib/alsa-lib/::" \
- "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
- fi
-
- prune_libtool_files --all
-}
-
-pkg_postinst() {
- if use pulseaudio; then
- einfo "The PulseAudio device is now set as the default device if the"
- einfo "PulseAudio server is found to be running. Any custom"
- einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
- einfo "purpose should now be unnecessary."
- fi
-}
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r3.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r3.ebuild
deleted file mode 100644
index f6644a93bd57..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r3.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils flag-o-matic multilib multilib-minimal
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-# TODO: handle USE=ffmpeg once it is converted
-
-RDEPEND=">=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
- ffmpeg? ( virtual/ffmpeg )
- jack? ( >=media-sound/jack-audio-connection-kit-0.121.3-r1[${MULTILIB_USEDEP}] )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
- pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
- speex? ( >=media-libs/speex-1.2_rc1-r1:=[${MULTILIB_USEDEP}] )
- abi_x86_32? (
- !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
- !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch \
- "${FILESDIR}"/${PN}-1.0.23-automagic.patch \
- "${FILESDIR}"/${P}-{ffmpeg,ffmpeg-version-check}.patch
-
- epatch_user
-
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i \
- -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- pulse/Makefile.am || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- use debug || append-cppflags -DNDEBUG
-
- local myspeex=no
- use speex && myspeex=lib
-
- ECONF_SOURCE=${S} \
- econf \
- $(multilib_native_use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- cd doc || die
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use ffmpeg && dodoc lavcrate.txt a52.txt
-
- if use pulseaudio; then
- dodoc README-pulse
- # install ALSA configuration files
- # making PA to be used by alsa clients
- insinto /usr/share/alsa
- doins "${FILESDIR}"/pulse-default.conf
- insinto /usr/share/alsa/alsa.conf.d
- doins "${FILESDIR}"/51-pulseaudio-probe.conf
- # bug #410261, comment 5+
- # seems to work fine without any path
- sed -i \
- -e "s:/usr/lib/alsa-lib/::" \
- "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
- fi
-
- prune_libtool_files --all
-}
-
-pkg_postinst() {
- if use pulseaudio; then
- einfo "The PulseAudio device is now set as the default device if the"
- einfo "PulseAudio server is found to be running. Any custom"
- einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
- einfo "purpose should now be unnecessary."
- fi
-}
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.28.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.28.ebuild
deleted file mode 100644
index cf86cb61c825..000000000000
--- a/media-plugins/alsa-plugins/alsa-plugins-1.0.28.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit autotools eutils flag-o-matic multilib multilib-minimal
-
-DESCRIPTION="ALSA extra plugins"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-linux"
-IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
-
-RDEPEND=">=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
- ffmpeg? ( virtual/ffmpeg[${MULTILIB_USEDEP}] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.121.3-r1[${MULTILIB_USEDEP}] )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
- pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
- speex? ( >=media-libs/speex-1.2_rc1-r1:=[${MULTILIB_USEDEP}] )
- abi_x86_32? (
- !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
- !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
-: epatch "${FILESDIR}"/${PN}-1.0.23-automagic.patch
-
- epatch_user
-
- # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
- # failed assert. As the code works just fine with asserts disabled, for now
- # disable them waiting for a better solution.
- sed -i \
- -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
- pulse/Makefile.am || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- use debug || append-cppflags -DNDEBUG
-
- local myspeex=no
- use speex && myspeex=lib
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable ffmpeg avcodec) \
- $(use_enable jack) \
- $(use_enable libsamplerate samplerate) \
- $(use_enable pulseaudio) \
- --with-speex=${myspeex}
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- cd doc || die
- dodoc upmix.txt vdownmix.txt README-pcm-oss
- use jack && dodoc README-jack
- use libsamplerate && dodoc samplerate.txt
- use ffmpeg && dodoc lavcrate.txt a52.txt
-
- if use pulseaudio; then
- dodoc README-pulse
- # install ALSA configuration files
- # making PA to be used by alsa clients
- insinto /usr/share/alsa
- doins "${FILESDIR}"/pulse-default.conf
- insinto /usr/share/alsa/alsa.conf.d
- doins "${FILESDIR}"/51-pulseaudio-probe.conf
- # bug #410261, comment 5+
- # seems to work fine without any path
- sed -i \
- -e "s:/usr/lib/alsa-lib/::" \
- "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
- fi
-
- prune_libtool_files --all
-}
-
-pkg_postinst() {
- if use pulseaudio; then
- einfo "The PulseAudio device is now set as the default device if the"
- einfo "PulseAudio server is found to be running. Any custom"
- einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
- einfo "purpose should now be unnecessary."
- fi
-}
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-missing-avutil.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-missing-avutil.patch
deleted file mode 100644
index 12acbbca1dcd..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.19-missing-avutil.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in_old 2009-01-26 21:46:07.000000000 +0100
-+++ configure.in 2009-01-26 21:47:25.000000000 +0100
-@@ -67,7 +67,7 @@
- AS_HELP_STRING([--disable-avcodec], [Don't build plugins depending on avcodec (a52)]))
-
- if test "x$enable_avcodec" != "xno"; then
-- PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
-+ PKG_CHECK_MODULES(AVCODEC, [libavcodec libavutil], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
- fi
-
- if test "x$HAVE_AVCODEC" = "xno"; then
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg-version-check.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg-version-check.patch
deleted file mode 100644
index 6b9b698471d2..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg-version-check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: alsa-plugins-1.0.27/a52/pcm_a52.c
-===================================================================
---- alsa-plugins-1.0.27.orig/a52/pcm_a52.c
-+++ alsa-plugins-1.0.27/a52/pcm_a52.c
-@@ -27,7 +27,7 @@
- #include <alsa/pcm_plugin.h>
- #include AVCODEC_HEADER
-
--#if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MINOR >= 34
-+#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(53,34,0)
- #include <libavutil/audioconvert.h>
- #include <libavutil/mem.h>
- #define USE_AVCODEC_FRAME
diff --git a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg.patch b/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg.patch
deleted file mode 100644
index 56f51e35a9c9..000000000000
--- a/media-plugins/alsa-plugins/files/alsa-plugins-1.0.27-ffmpeg.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 367e208954711fabe159070d242927246ed821cd Mon Sep 17 00:00:00 2001
-From: Anton Khirnov <anton@khirnov.net>
-Date: Thu, 9 Jan 2014 21:14:17 +0100
-Subject: [PATCH] a52: switch to AV_CODEC_ID identifiers
-
-Fixes build with latest libavcodec versions.
-
-Signed-off-by: Takashi Iwai <tiwai@suse.de>
----
- a52/pcm_a52.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/a52/pcm_a52.c b/a52/pcm_a52.c
-index 359608f..b467ec8 100644
---- a/a52/pcm_a52.c
-+++ b/a52/pcm_a52.c
-@@ -58,6 +58,9 @@
- #endif
- #endif
-
-+#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54, 25, 0)
-+#define AV_CODEC_ID_AC3 CODEC_ID_AC3
-+#endif
-
- struct a52_ctx {
- snd_pcm_ioplug_t io;
-@@ -916,7 +919,7 @@ SND_PCM_PLUGIN_DEFINE_FUNC(a52)
- if (rec->codec == NULL)
- rec->codec = avcodec_find_encoder_by_name("ac3");
- if (rec->codec == NULL)
-- rec->codec = avcodec_find_encoder(CODEC_ID_AC3);
-+ rec->codec = avcodec_find_encoder(AV_CODEC_ID_AC3);
- if (rec->codec == NULL) {
- SNDERR("Cannot find codec engine");
- err = -EINVAL;
---
-1.7.11.7
-