summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:07:32 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-06 20:09:02 -0400
commite4116fc198036810823cacc954ba255ca1cf9e8b (patch)
treee7d31d2bc1812883a0049eae720d2889a697d0c7
parentdev-perl/ORLite-Migrate: Fix '.' in @INC test failures (diff)
downloadgentoo-e4116fc198036810823cacc954ba255ca1cf9e8b.tar.gz
gentoo-e4116fc198036810823cacc954ba255ca1cf9e8b.tar.bz2
gentoo-e4116fc198036810823cacc954ba255ca1cf9e8b.zip
Initial commit. Required by weasyprint.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-python/pytest-flake8/Manifest1
-rw-r--r--dev-python/pytest-flake8/metadata.xml16
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
new file mode 100644
index 000000000000..1bb722a7517a
--- /dev/null
+++ b/dev-python/pytest-flake8/Manifest
@@ -0,0 +1 @@
+DIST pytest-flake8-0.8.1.tar.gz 7359 SHA256 aa10a6db147485d71dad391d4149388904c3072194d51755f64784ff128845fd SHA512 b49b4d42712040492161f144cce807b661f2d8fe5b484b29ad1a519fd5b0b0cfb6abd42c3ae8999f21263c4776fb773f91bf0776971b6b6727607d33fb49ca89 WHIRLPOOL a1e5531216244617e647f10c0550c8a1b9c74929b0b1dec4d392930b02fbb699e15209ebd705e3571012d7cf7c81ecd0427f5a10e00c61e70dec00917caebb8e
diff --git a/dev-python/pytest-flake8/metadata.xml b/dev-python/pytest-flake8/metadata.xml
new file mode 100644
index 000000000000..2ef8e4f36f30
--- /dev/null
+++ b/dev-python/pytest-flake8/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-flake8</remote-id>
+ <remote-id type="github">tholo/pytest-flake8</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
new file mode 100644
index 000000000000..3023f8be88d9
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"