summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-16 20:14:46 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-16 20:15:12 +0200
commite49fe8d27cc68e57ba75cb55d0c6dbcf47ccf1d7 (patch)
treeff82118cc406f1809addf685f064257cdedb2b18
parentapp-crypt/nitrokey-app: Fix installing bash auto-completion (diff)
downloadgentoo-e49fe8d27cc68e57ba75cb55d0c6dbcf47ccf1d7.tar.gz
gentoo-e49fe8d27cc68e57ba75cb55d0c6dbcf47ccf1d7.tar.bz2
gentoo-e49fe8d27cc68e57ba75cb55d0c6dbcf47ccf1d7.zip
media-libs/libheif: Add USE=gdk-pixbuf
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Closes: https://bugs.gentoo.org/704746 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--media-libs/libheif/libheif-1.7.0.ebuild4
-rw-r--r--media-libs/libheif/libheif-9999.ebuild4
-rw-r--r--media-libs/libheif/metadata.xml3
3 files changed, 8 insertions, 3 deletions
diff --git a/media-libs/libheif/libheif-1.7.0.ebuild b/media-libs/libheif/libheif-1.7.0.ebuild
index c7406ee8a8ef..3bba1148615d 100644
--- a/media-libs/libheif/libheif-1.7.0.ebuild
+++ b/media-libs/libheif/libheif-1.7.0.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.6"
-IUSE="go static-libs test +threads"
+IUSE="gdk-pixbuf go static-libs test +threads"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -28,6 +28,7 @@ DEPEND="
media-libs/x265:=[${MULTILIB_USEDEP}]
sys-libs/zlib:=[${MULTILIB_USEDEP}]
virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
go? ( dev-lang/go )
"
RDEPEND="${DEPEND}"
@@ -49,6 +50,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
$(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
)
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index 85e13a9e4cfc..3e1aacd0ed3d 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.6"
-IUSE="go static-libs test +threads"
+IUSE="gdk-pixbuf go static-libs test +threads"
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -28,6 +28,7 @@ DEPEND="
media-libs/x265:=[${MULTILIB_USEDEP}]
sys-libs/zlib:=[${MULTILIB_USEDEP}]
virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
go? ( dev-lang/go )
"
RDEPEND="${DEPEND}"
@@ -46,6 +47,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
$(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
)
diff --git a/media-libs/libheif/metadata.xml b/media-libs/libheif/metadata.xml
index 481879a14425..f92d3bad5e85 100644
--- a/media-libs/libheif/metadata.xml
+++ b/media-libs/libheif/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
- <flag name='go'>Add support for <pkg>dev-lang/go</pkg></flag>
+ <flag name='gdk-pixbuf'>Enable <pkg>x11-libs/gdk-pixbuf</pkg> plugin</flag>
+ <flag name='go'>Enable building <pkg>dev-lang/go</pkg> code/examples</flag>
</use>
<upstream>
<bugs-to>https://github.com/strukturag/libheif/issues</bugs-to>