summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-01 02:52:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-01 02:55:53 +0100
commite4c36e7e9a47e830fd712d37197a74cb5c4f29b0 (patch)
treeaa2fe9ff30675a16c839c20ab1960577bac67978
parentsci-misc/vitables: Remove old (py3.6) (diff)
downloadgentoo-e4c36e7e9a47e830fd712d37197a74cb5c4f29b0.tar.gz
gentoo-e4c36e7e9a47e830fd712d37197a74cb5c4f29b0.tar.bz2
gentoo-e4c36e7e9a47e830fd712d37197a74cb5c4f29b0.zip
sci-physics/espresso: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-physics/espresso/Manifest2
-rw-r--r--sci-physics/espresso/espresso-4.0.0-r2.ebuild118
-rw-r--r--sci-physics/espresso/espresso-4.0_pre20170228.ebuild120
-rw-r--r--sci-physics/espresso/files/1056.patch190
-rw-r--r--sci-physics/espresso/files/2277.patch19
5 files changed, 0 insertions, 449 deletions
diff --git a/sci-physics/espresso/Manifest b/sci-physics/espresso/Manifest
index a4941b7d1888..366b7e767003 100644
--- a/sci-physics/espresso/Manifest
+++ b/sci-physics/espresso/Manifest
@@ -1,3 +1 @@
-DIST espresso-4.0.0.tar.gz 25767191 BLAKE2B 995678496fe35b957c4a5775f79f6656efbb5f717a43e90f8c5fa406aba7847cd34b00db3f313e5a7b0a11a96b521e8182bdd58129ad68ea4881c9496e3977e5 SHA512 53eb311e8bb7db5aed32dcd3adfd5e1c63e6ae42a22cea41844edfa857fee03ffd717c0739dd46a6cdf8ca7a4c4b0952a036b208fccc4e61de3f383910e7d019
-DIST espresso-4.0_pre20170228.tar.gz 23621395 BLAKE2B 6381e519c59986e50ff74fb3d81cd157f4761e1c46ea96b384487fd079b9c6f881dfa70df8f62e275fdd57bda6a4c714002630cebb02c232029186c3adbb692f SHA512 7d35648d447af3282a76d9d68cfe681734ec18794a38b09e0ae9233f63b62450c643643bcec999ea9c7d4ba070d4fc6f8dc64db8145f536ae017a67ff2d0e0e2
DIST espresso-4.1.3.tar.gz 16947336 BLAKE2B 14d3513eda87f62a8473a0cac0c273b3590bf78ed48b96e76d10c106713f7bbd7d37de951bd3d9210062b34c02bd83a68f3aaf1ca8215ed1dcde590e4e99b113 SHA512 1fe82683eddb7bfd9bae6e446b0f42a50087d755995963905cd419473ad17b204f20049d0cf4af9264898dd6fee36f02744b38fa45cd0e33086374cf2aebd934
diff --git a/sci-physics/espresso/espresso-4.0.0-r2.ebuild b/sci-physics/espresso/espresso-4.0.0-r2.ebuild
deleted file mode 100644
index 0afbf393e9a9..000000000000
--- a/sci-physics/espresso/espresso-4.0.0-r2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils python-single-r1 savedconfig
-
-DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
-HOMEPAGE="http://espressomd.org"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
- EGIT_BRANCH="python"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}md/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="cuda doc examples +fftw +hdf5 test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/cython-0.26.1[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')
- cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
- fftw? ( sci-libs/fftw:3.0 )
- dev-libs/boost:=[mpi]
- hdf5? ( sci-libs/hdf5:=[mpi] )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-latexextra
- virtual/latex-base )"
-
-DOCS=( AUTHORS NEWS README ChangeLog )
-
-PATCHES=( "${FILESDIR}/2277.patch" )
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- -DWITH_CUDA=$(usex cuda)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DWITH_TESTS=$(usex test)
- -DINSTALL_PYPRESSO=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
- -DWITH_HDF5=$(usex hdf5)
- -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
- -DCMAKE_SKIP_RPATH=YES
- -DLIBDIR=$(get_libdir)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake-utils_src_make ug dg tutorials
-}
-
-src_install() {
- local i docdir="${S}"
-
- cmake-utils_src_install
-
- insinto /usr/share/${PN}/
- doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
-
- save_config ${CMAKE_BUILD_DIR}/src/core/myconfig-final.hpp
-
- if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${CMAKE_BUILD_DIR}"
- newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
- newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
- for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
- newdoc "${i}" "tutorial_${i##*/}"
- done
- dodoc -r ${CMAKE_BUILD_DIR}/doc/doxygen/html
- fi
-
- if use examples; then
- insinto "/usr/share/${PN}/examples/python"
- doins -r samples/${i}/.
- fi
-}
-
-pkg_postinst() {
- echo
- elog "Please read and cite:"
- elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
- elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
- echo
- elog "If you need more features, change"
- elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
- elog "and reemerge with USE=savedconfig"
- echo
- elog "For a full feature list see:"
- elog "/usr/share/${PN}/myconfig-sample.hpp"
- echo
-}
diff --git a/sci-physics/espresso/espresso-4.0_pre20170228.ebuild b/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
deleted file mode 100644
index e7c540b16298..000000000000
--- a/sci-physics/espresso/espresso-4.0_pre20170228.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-CMAKE_MAKEFILE_GENERATOR="ninja"
-
-inherit cmake-utils python-single-r1 savedconfig
-
-DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
-HOMEPAGE="http://espressomd.org"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
- EGIT_BRANCH="master"
- inherit git-r3
- KEYWORDS=""
-else
- inherit vcs-snapshot
- COMMIT="8a021f5e8b1d508f356f4419d360bd9dfb7fec2c"
- SRC_URI="https://github.com/${PN}md/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="cuda doc examples +fftw +hdf5 test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >dev-python/cython-0.22[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- ')
- cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
- fftw? ( sci-libs/fftw:3.0 )
- dev-libs/boost:=[mpi]
- hdf5? ( sci-libs/hdf5:=[cxx] )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-latexextra
- virtual/latex-base )"
-
-DOCS=( AUTHORS NEWS README ChangeLog )
-
-PATCHES=( "${FILESDIR}"/1056.patch )
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- -DWITH_CUDA=$(usex cuda)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DWITH_TESTS=$(usex test)
- -DWITH_SCAFACOS=ON
- -DINSTALL_PYPRESSO=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
- -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
- -DCMAKE_SKIP_RPATH=YES
- -DLIBDIR=$(get_libdir)
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake-utils_src_make ug dg tutorials
-}
-
-src_install() {
- local i docdir="${S}"
-
- cmake-utils_src_install
-
- insinto /usr/share/${PN}/
- doins ${CMAKE_BUILD_DIR}/myconfig-sample.hpp
-
- save_config ${CMAKE_BUILD_DIR}/src/core/myconfig-final.hpp
-
- if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${CMAKE_BUILD_DIR}"
- newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
- newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
- for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
- newdoc "${i}" "tutorial_${i##*/}"
- done
- dodoc -r ${CMAKE_BUILD_DIR}/doc/doxygen/html
- fi
-
- if use examples; then
- insinto "/usr/share/${PN}/examples/"
- doins -r samples/python/.
- fi
-}
-
-pkg_postinst() {
- echo
- elog "Please read and cite:"
- elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
- elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
- echo
- elog "If you need more features, change"
- elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
- elog "and reemerge with USE=savedconfig"
- echo
- elog "For a full feature list see:"
- elog "/usr/share/${PN}/myconfig-sample.hpp"
- echo
-}
diff --git a/sci-physics/espresso/files/1056.patch b/sci-physics/espresso/files/1056.patch
deleted file mode 100644
index 18a478e446b1..000000000000
--- a/sci-physics/espresso/files/1056.patch
+++ /dev/null
@@ -1,190 +0,0 @@
-From d075cbaa80ce0b484c8422be27c5b5680f6abee4 Mon Sep 17 00:00:00 2001
-From: Christoph Junghans <junghans@votca.org>
-Date: Fri, 3 Mar 2017 16:05:45 -0700
-Subject: [PATCH] cmake: install all shared libs in back in libdir
-
-some libraries weren't installed and the python module path
-isn't in the LD_LIBRARY_PATH and hence partly revert
-80ad49e954f4a6590707fd86e4fd586682ad626d
----
- CMakeLists.txt | 4 ++++
- src/core/CMakeLists.txt | 4 ++--
- src/core/actor/CMakeLists.txt | 4 ++--
- src/core/constraints/CMakeLists.txt | 1 +
- src/core/correlators/CMakeLists.txt | 1 +
- src/core/immersed_boundary/CMakeLists.txt | 4 ++--
- src/core/object-in-fluid/CMakeLists.txt | 2 +-
- src/core/observables/CMakeLists.txt | 1 +
- src/core/scafacos/CMakeLists.txt | 2 +-
- src/core/shapes/CMakeLists.txt | 1 +
- src/core/utils/CMakeLists.txt | 1 +
- src/script_interface/CMakeLists.txt | 1 +
- 12 files changed, 18 insertions(+), 8 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index cf49c40..7a8bc15 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -238,6 +238,10 @@ if (NOT DEFINED DATA)
- set(DATA "share/espresso")
- endif(NOT DEFINED DATA)
-
-+if (NOT DEFINED LIBDIR)
-+ set(LIBDIR "lib")
-+endif(NOT DEFINED LIBDIR)
-+
- if (NOT DEFINED BINDIR)
- set(BINDIR "bin")
- endif(NOT DEFINED BINDIR)
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index 9982a54..13bb052 100644
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -23,7 +23,7 @@ add_custom_target(EspressoConfig DEPENDS config-features.hpp config-features.cpp
- add_dependencies(EspressoConfig myconfig)
-
- add_library(EspressoCore SHARED ${EspressoCore_SRC} config-features.cpp config-version.cpp)
--install(TARGETS EspressoCore LIBRARY DESTINATION ${PYTHON_INSTDIR})
-+install(TARGETS EspressoCore LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(EspressoCore EspressoConfig)
-
- target_link_libraries(EspressoCore ${LIBRARIES} Actor ObjectInFluid ImmersedBoundary Shapes Constraints EspressoUtils Correlators Observables)
-@@ -43,7 +43,7 @@ if(CUDA)
- cuda_include_directories(${CMAKE_CURRENT_BINARY_DIR})
-
- cuda_add_library(EspressoCuda SHARED ${EspressoCuda_SRC})
-- install(TARGETS EspressoCuda DESTINATION ${PYTHON_INSTDIR})
-+ install(TARGETS EspressoCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
- add_dependencies(EspressoCuda EspressoConfig)
-
- set_target_properties(EspressoCuda PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/actor/CMakeLists.txt b/src/core/actor/CMakeLists.txt
-index 0421243..1b5eafe 100644
---- a/src/core/actor/CMakeLists.txt
-+++ b/src/core/actor/CMakeLists.txt
-@@ -1,7 +1,7 @@
- file(GLOB Actor_SRC *.cpp)
-
- add_library(Actor SHARED ${Actor_SRC})
--install(TARGETS Actor LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
-+install(TARGETS Actor LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
- add_dependencies(Actor EspressoConfig)
-
- set_target_properties(Actor PROPERTIES MACOSX_RPATH TRUE)
-@@ -9,7 +9,7 @@ set_target_properties(Actor PROPERTIES MACOSX_RPATH TRUE)
- if(CUDA)
- file(GLOB ActorCuda_SRC *.cu)
- cuda_add_library(ActorCuda SHARED ${ActorCuda_SRC})
-- install(TARGETS ActorCuda DESTINATION ${PYTHON_INSTDIR})
-+ install(TARGETS ActorCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
- add_dependencies(ActorCuda EspressoConfig)
-
- add_dependencies(Actor ActorCuda)
-diff --git a/src/core/constraints/CMakeLists.txt b/src/core/constraints/CMakeLists.txt
-index 0f5c043..d07ad77 100644
---- a/src/core/constraints/CMakeLists.txt
-+++ b/src/core/constraints/CMakeLists.txt
-@@ -1,4 +1,5 @@
- file(GLOB Constraints_SRC Constraint.cpp)
- add_library(Constraints SHARED ${Constraints_SRC})
-+install(TARGETS Constraints LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(Constraints EspressoConfig)
- set_target_properties(Constraints PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/correlators/CMakeLists.txt b/src/core/correlators/CMakeLists.txt
-index c5ff02f..fcc3611 100644
---- a/src/core/correlators/CMakeLists.txt
-+++ b/src/core/correlators/CMakeLists.txt
-@@ -1,4 +1,5 @@
- file(GLOB Correlators_SRC *.?pp)
- add_library(Correlators SHARED ${Correlators_SRC})
-+install(TARGETS Correlators LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(Correlators EspressoConfig)
- set_target_properties(Correlators PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/immersed_boundary/CMakeLists.txt b/src/core/immersed_boundary/CMakeLists.txt
-index ec7fb85..8e7285f 100644
---- a/src/core/immersed_boundary/CMakeLists.txt
-+++ b/src/core/immersed_boundary/CMakeLists.txt
-@@ -1,13 +1,13 @@
- file(GLOB ImmersedBoundary_SRC *.cpp)
- add_library(ImmersedBoundary SHARED ${ImmersedBoundary_SRC})
- set_target_properties(ImmersedBoundary PROPERTIES MACOSX_RPATH TRUE)
--install(TARGETS ImmersedBoundary LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
-+install(TARGETS ImmersedBoundary LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
- add_dependencies(ImmersedBoundary EspressoConfig)
-
- if(CUDA)
- file(GLOB ImmersedBoundaryCuda_SRC *.cu)
- cuda_add_library(ImmersedBoundaryCuda SHARED ${ImmersedBoundaryCuda_SRC})
-- install(TARGETS ImmersedBoundaryCuda DESTINATION ${PYTHON_INSTDIR})
-+ install(TARGETS ImmersedBoundaryCuda DESTINATION ${PYTHON_INSTDIR}/espressomd)
- add_dependencies(ImmersedBoundaryCuda EspressoConfig)
-
- set_target_properties(ImmersedBoundaryCuda PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/object-in-fluid/CMakeLists.txt b/src/core/object-in-fluid/CMakeLists.txt
-index 7154486..c25228a 100644
---- a/src/core/object-in-fluid/CMakeLists.txt
-+++ b/src/core/object-in-fluid/CMakeLists.txt
-@@ -1,5 +1,5 @@
- file(GLOB ObjectInFluid_SRC *.cpp)
- add_library(ObjectInFluid SHARED ${ObjectInFluid_SRC})
--install(TARGETS ObjectInFluid LIBRARY DESTINATION ${PYTHON_INSTDIR} ARCHIVE DESTINATION ${PYTHON_INSTDIR})
-+install(TARGETS ObjectInFluid LIBRARY DESTINATION ${LIBDIR} ARCHIVE DESTINATION ${LIBDIR})
- add_dependencies(ObjectInFluid EspressoConfig)
- set_target_properties(ObjectInFluid PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/observables/CMakeLists.txt b/src/core/observables/CMakeLists.txt
-index 9813d86..51ab79d 100644
---- a/src/core/observables/CMakeLists.txt
-+++ b/src/core/observables/CMakeLists.txt
-@@ -1,4 +1,5 @@
- file(GLOB Observables_SRC *.?pp)
- add_library(Observables SHARED ${Observables_SRC})
-+install(TARGETS Observables LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(Observables EspressoConfig)
- set_target_properties(Observables PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/scafacos/CMakeLists.txt b/src/core/scafacos/CMakeLists.txt
-index 1479683..3028ca0 100644
---- a/src/core/scafacos/CMakeLists.txt
-+++ b/src/core/scafacos/CMakeLists.txt
-@@ -2,7 +2,7 @@ include_directories(${SCAFACOS_INCLUDE_DIRS})
-
- file(GLOB Scafacos_SRC *.cpp)
- add_library(Scafacos SHARED ${Scafacos_SRC})
--install(TARGETS Scafacos DESTINATION ${PYTHON_INSTDIR})
-+install(TARGETS Scafacos DESTINATION ${PYTHON_INSTDIR}/espressomd)
- add_dependencies(Scafacos EspressoConfig)
-
- target_link_libraries(Scafacos ${SCAFACOS_LDFLAGS})
-diff --git a/src/core/shapes/CMakeLists.txt b/src/core/shapes/CMakeLists.txt
-index 0e5ecaa..5be3a9d 100644
---- a/src/core/shapes/CMakeLists.txt
-+++ b/src/core/shapes/CMakeLists.txt
-@@ -1,4 +1,5 @@
- file(GLOB Shapes_SRC *.cpp)
- add_library(Shapes SHARED ${Shapes_SRC})
-+install(TARGETS Shapes LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(Shapes EspressoConfig)
- set_target_properties(Shapes PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/core/utils/CMakeLists.txt b/src/core/utils/CMakeLists.txt
-index ec0f6f7..4cd8ada 100644
---- a/src/core/utils/CMakeLists.txt
-+++ b/src/core/utils/CMakeLists.txt
-@@ -1,3 +1,4 @@
- file(GLOB EspressoUtils_SRC *.cpp)
- add_library(EspressoUtils SHARED ${EspressoUtils_SRC})
-+install(TARGETS EspressoUtils LIBRARY DESTINATION ${LIBDIR})
- set_target_properties(EspressoUtils PROPERTIES MACOSX_RPATH TRUE)
-diff --git a/src/script_interface/CMakeLists.txt b/src/script_interface/CMakeLists.txt
-index 8aff034..59c1c9d 100644
---- a/src/script_interface/CMakeLists.txt
-+++ b/src/script_interface/CMakeLists.txt
-@@ -28,6 +28,7 @@ if(H5MD)
- )
- endif(H5MD)
- add_library(EspressoScriptInterface SHARED ${EspressoScriptInterface_SRC})
-+install(TARGETS EspressoScriptInterface LIBRARY DESTINATION ${LIBDIR})
- add_dependencies(EspressoScriptInterface EspressoConfig EspressoConfig)
- set_target_properties(EspressoScriptInterface PROPERTIES MACOSX_RPATH TRUE)
- target_link_libraries(EspressoScriptInterface EspressoCore)
---
-2.10.2
-
diff --git a/sci-physics/espresso/files/2277.patch b/sci-physics/espresso/files/2277.patch
deleted file mode 100644
index 608bd2876121..000000000000
--- a/sci-physics/espresso/files/2277.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 46110a514ce2420a350cca8b9af28e0c4eb51861 Mon Sep 17 00:00:00 2001
-From: Christoph Junghans <junghans@votca.org>
-Date: Fri, 21 Sep 2018 06:57:16 -0600
-Subject: [PATCH] cmake: install libH5mdCore
-
----
- src/core/io/writer/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/core/io/writer/CMakeLists.txt b/src/core/io/writer/CMakeLists.txt
-index e677ba273a..42b96c96af 100644
---- a/src/core/io/writer/h5md/CMakeLists.txt
-+++ b/src/core/io/writer/h5md/CMakeLists.txt
-@@ -4,4 +4,5 @@
- "${CMAKE_SOURCE_DIR}/libs/h5xx"
- )
- add_dependencies(H5mdCore EspressoConfig)
-+install(TARGETS H5mdCore LIBRARY DESTINATION ${LIBDIR})
-