summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-12-26 10:22:08 +0100
committerFabian Groffen <grobian@gentoo.org>2019-12-26 10:22:08 +0100
commite51c8f7c6081fd5cab93d33984a66b246e72a949 (patch)
tree23e6b8cf94c4bf934a3d623002cca794de57aee5
parentsys-libs/csu: revbump to respect CFLAGS (diff)
downloadgentoo-e51c8f7c6081fd5cab93d33984a66b246e72a949.tar.gz
gentoo-e51c8f7c6081fd5cab93d33984a66b246e72a949.tar.bz2
gentoo-e51c8f7c6081fd5cab93d33984a66b246e72a949.zip
sys-libs/csu: bump to EAPI=7
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-libs/csu/csu-85-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-libs/csu/csu-85-r1.ebuild b/sys-libs/csu/csu-85-r1.ebuild
index 28ea492c1a5d..8c9ad7d9a737 100644
--- a/sys-libs/csu/csu-85-r1.ebuild
+++ b/sys-libs/csu/csu-85-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="Darwin Csu (crt1.o) - Mac OS X 10.10 version"
HOMEPAGE="http://www.opensource.apple.com/"
@@ -33,7 +33,7 @@ src_prepare() {
Makefile || die
# only require Availability.h for arm, bugs #538602, #539964
- epatch "${FILESDIR}"/${P}-arm-availability.patch
+ eapply "${FILESDIR}"/${P}-arm-availability.patch
if [[ ${CHOST} == powerpc* ]] ; then
# *must not* be compiled with -Os on PPC because that
@@ -44,6 +44,8 @@ src_prepare() {
# be more than 16MB away
sed -i -e "s, -Os , -O ,g" Makefile || die
fi
+
+ eapply_user
}
src_compile() {