summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-09-21 20:37:36 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-09-21 20:48:29 +0200
commite539415bbc8f84241a615f5b46489ffc466859b3 (patch)
treee987a9725517a4dff9ce9a0203ea1baadd4409c4
parentkde-plasma/kwin: Fix build on 32-bit (diff)
downloadgentoo-e539415bbc8f84241a615f5b46489ffc466859b3.tar.gz
gentoo-e539415bbc8f84241a615f5b46489ffc466859b3.tar.bz2
gentoo-e539415bbc8f84241a615f5b46489ffc466859b3.zip
dev-util/intel-graphics-compiler: bump to version 1.0.8708
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 2d2471a91dc0..5234b67802a2 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
DIST intel-graphics-compiler-1.0.8365.tar.gz 7509633 BLAKE2B ffe18d18b409db36bd24215d841daaa36d5055d61b9021e385fe9178351b6a92383839e271a12d1e5017150b9697060fe37f803c5153d2f107813aeb2e7a74cf SHA512 6597afbab2c101d69e6a991b5b065ebbded7ccc6227c0ed82b6b0bd33fec26489c30a0a7a9558617578a767ca6d7382a6ab36144f4c64df742c6bd545ce991e9
DIST intel-graphics-compiler-1.0.8517.tar.gz 7539946 BLAKE2B 034d2e3dcfc25186e29eebfabffbca7b8a5adab1f766c7515b4a3206c9c52eca3dd766e17320ea0c40067385fc6235d92eec13f1d12909915b86fb42a7862825 SHA512 35f09d1f6b117e78814cc235d03b1f1164f11a2d2a5d188b6658677c4b759422048764e765f7690f4789dc8b8c068714a68642c2d956ccc84b387a959f9af07f
+DIST intel-graphics-compiler-1.0.8708.tar.gz 7574517 BLAKE2B 578b29a103d3d0b7f481971a801fa11bc14430b7ecd00c99492f5d80ce713b84d00d278726a425edf5884ac15f4877c96a39a3f3f3f1c22bc972db039be28dc2 SHA512 3685c2fe0750d860facd7f378a1de4ac21127e7720d7a8889ac0ae8ab9e58dfacfc50b5bbe37d5744c9a17958b057512871125b58784a8c62ddffc2997f80ba8
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild
new file mode 100644
index 000000000000..0e7e9889129e
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8708.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE="Release"
+LLVM_MAX_SLOT="11"
+MY_PN="igc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake flag-o-matic llvm python-any-r1
+
+DESCRIPTION="LLVM-based OpenCL compiler for OpenCL targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/opencl-clang:${LLVM_MAX_SLOT}=
+ sys-devel/llvm:${LLVM_MAX_SLOT}=
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-devel/lld-${LLVM_MAX_SLOT}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
+ "${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
+ "${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
+ "${FILESDIR}/${PN}-1.0.8365-cmake-project.patch"
+)
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # Since late March 2020 cmake.eclass does not set -DNDEBUG any more,
+ # and the way IGC uses this definition causes problems for some users.
+ # See bug #718824 for more information.
+ ! use debug && append-cppflags -DNDEBUG
+
+ # Get LLVM version
+ local llvm_version="$(best_version -d sys-devel/llvm:${LLVM_MAX_SLOT})"
+
+ local mycmakeargs=(
+ # Those options are ensuring, that we are using
+ # the system LLVM with the correct slot.
+ -DCCLANG_SONAME_VERSION="${LLVM_MAX_SLOT}"
+ -DCMAKE_LIBRARY_PATH="$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)"
+ -DIGC_OPTION__ARCHITECTURE_TARGET="Linux64"
+ -DIGC_OPTION__CLANG_MODE="Prebuilds"
+ -DIGC_OPTION__LLD_MODE="Prebuilds"
+ -DIGC_OPTION__LLDELF_H_DIR="${EPREFIX}/usr/include/lld/Common"
+ -DIGC_OPTION__LLVM_MODE="Prebuilds"
+ -DIGC_OPTION__LLVM_PREFERRED_VERSION="${llvm_version##*-}"
+
+ # VectorCompiler needs work, as at the moment upstream
+ # only supports building vc-intrinsics in place.
+ -DIGC_BUILD__VC_ENABLED="NO"
+
+ # This will suspress some CMake warnings,
+ # which cannot be fixed at the moment.
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}