summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:00:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-13 14:03:48 +0100
commite549743c24bf236978f446e5429273c09b79d65d (patch)
tree11abd6cf26daf70f9467883d92c7b14dc30a305a
parentkde-frameworks/kauth: 5.79.0 version bump (diff)
downloadgentoo-e549743c24bf236978f446e5429273c09b79d65d.tar.gz
gentoo-e549743c24bf236978f446e5429273c09b79d65d.tar.bz2
gentoo-e549743c24bf236978f446e5429273c09b79d65d.zip
kde-frameworks/kcompletion: 5.79.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.79.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index c4d5dc97a36f..949cff819860 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.77.0.tar.xz 121432 BLAKE2B ca1b4bd3cd2459891dbe44a90fdd48a6f2a14529598f70dfa354e0fc44a840b2f058e7aa43cf030cf0c98b37e001f2cc18a618ad39d5e04dc576ce2b7064a925 SHA512 1dbce42fab7d640083ec936586d89878d2b05c2a341bf6cdd58571b306600b8864d100a84cbfbc4d110bc5c87f6b07fe20859558d9b60e1927a012b98a67b87e
DIST kcompletion-5.78.0.tar.xz 121480 BLAKE2B 3904ef1a7130b4d05f09399994ce4cc56078d9cdcab9dd6edd302477bd681ec7dfd5f71d338ae6e15f310877ece58f6728b1eaa478083222ee4c4972e7193dcd SHA512 29fbc9c56a34601a4c674c45d04a3d2b79beebe0484c2dc80bf7a9a71de9c8ee82b548bd8d3df521593a60e37f0789d9e23eec5058fab9c3bfee2e53c8d6f58a
+DIST kcompletion-5.79.0.tar.xz 121808 BLAKE2B b608d9728ce2ce1d51075cea00f1ede61881a8f8b14d2eddf85fc9e0baccd585d7b86b2683c8d09dd4dcaca9ab35607a430482ab9fb1176ee886e43676b9ad45 SHA512 bcea7a8269f374cd813b31fb3b64c1e9af6b72e835bede02c68ce002731df7a6347c10f6df15b56d5c447f89f386888b8c31a48d9f66e14967d7fbcd0e7f1097
diff --git a/kde-frameworks/kcompletion/kcompletion-5.79.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.79.0.ebuild
new file mode 100644
index 000000000000..a0fa08fde404
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.79.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}