summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-21 15:49:29 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-21 15:49:29 +0200
commite551399e2f1a78e5037eb8930c0a53e11d97618c (patch)
tree86503eb9d2c0ad99769355241a9204759a5008c2
parentapp-antivirus/clamav: new revision to unbundle tomsfastmath. (diff)
downloadgentoo-e551399e2f1a78e5037eb8930c0a53e11d97618c.tar.gz
gentoo-e551399e2f1a78e5037eb8930c0a53e11d97618c.tar.bz2
gentoo-e551399e2f1a78e5037eb8930c0a53e11d97618c.zip
sci-biology/mcl: [QA] Call AM_PROG_AR
Closes: https://bugs.gentoo.org/725326 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-biology/mcl/files/mcl-14.137-fix-autotools.patch52
-rw-r--r--sci-biology/mcl/mcl-14.137.ebuild16
2 files changed, 59 insertions, 9 deletions
diff --git a/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch b/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch
new file mode 100644
index 000000000000..0d2c052a91b0
--- /dev/null
+++ b/sci-biology/mcl/files/mcl-14.137-fix-autotools.patch
@@ -0,0 +1,52 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -144,6 +144,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ # Checks for libraries.
+ # FIXME: Replace `main' with a function in `-lm':
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -9,7 +9,6 @@
+ ## http://www.w3.org/People/Raggett/tidy/ , by Dave Raggett <dsr@w3.org>
+ TIDY = tidy
+
+-docdir = $(datadir)/doc/$(PACKAGE)
+
+ # mclfamily.html mclfamily.ps
+
+--- a/graphs/Makefile.am
++++ b/graphs/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+ ## $Id: Makefile.am,v 1.7 2007-01-29 11:35:37 flux Exp $
+
+-exampledir = $(datadir)/doc/$(PACKAGE)/examples
++exampledir = $(docdir)/examples
+
+ example_DATA = falkner.mci falkner2.mci falkner.coords make-falkner.pl \
+ proteins.mci matula.mci lattice.mci honey.mci seven.mci infinity.mci \
+--- a/img/Makefile.am
++++ b/img/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+ ## $Id: Makefile.am,v 1.7 2007-01-29 11:35:37 flux Exp $
+
+-exampledir = $(datadir)/doc/$(PACKAGE)/examples
++exampledir = $(docdir)/examples
+
+ example_DATA = fa_1024.png fa_400.png fa_600.png fa_large.png fa.ps falkner-bidi.ps falkner.ps small.ps small.png
+
+--- a/src/alien/oxygen/doc/Makefile.am
++++ b/src/alien/oxygen/doc/Makefile.am
+@@ -17,7 +17,6 @@
+ ## http://www.w3.org/People/Raggett/tidy/ , by Dave Raggett <dsr@w3.org>
+ TIDY = tidy
+
+-docdir = $(datadir)/doc/$(PACKAGE)
+
+ ## zoemtut.html is "on hold": do not install; zoem is not yet ready
+ ## for prime time
diff --git a/sci-biology/mcl/mcl-14.137.ebuild b/sci-biology/mcl/mcl-14.137.ebuild
index e48198deca29..40c96e8a4b12 100644
--- a/sci-biology/mcl/mcl-14.137.ebuild
+++ b/sci-biology/mcl/mcl-14.137.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -16,16 +16,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+blast"
-PATCHES=("${FILESDIR}/${P}-qa-implicit-declarations.patch")
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-qa-implicit-declarations.patch
+ "${FILESDIR}"/${P}-fix-autotools.patch
+)
+
src_prepare() {
- find \
- -name Makefile.am \
- -exec sed \
- -e '/docdir/d' \
- -e '/exampledir/s:doc::g' \
- -i '{}' + || die
default
eautoreconf
}