summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-17 00:21:00 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-17 00:21:00 +0100
commite606af941b0e308edd7e4ee3dde23a41fcefea7c (patch)
tree4ed6e84ccf4c2d4a242fc89edca2e49022121259
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-e606af941b0e308edd7e4ee3dde23a41fcefea7c.tar.gz
gentoo-e606af941b0e308edd7e4ee3dde23a41fcefea7c.tar.bz2
gentoo-e606af941b0e308edd7e4ee3dde23a41fcefea7c.zip
sci-calculators/wcalc: port to EAPI 7
Closes: https://bugs.gentoo.org/725378 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-calculators/wcalc/files/wcalc-2.5-AR.patch10
-rw-r--r--sci-calculators/wcalc/wcalc-2.5.ebuild13
2 files changed, 20 insertions, 3 deletions
diff --git a/sci-calculators/wcalc/files/wcalc-2.5-AR.patch b/sci-calculators/wcalc/files/wcalc-2.5-AR.patch
new file mode 100644
index 000000000000..03291019d29e
--- /dev/null
+++ b/sci-calculators/wcalc/files/wcalc-2.5-AR.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,6 +46,7 @@ AC_PROG_CC
+ AC_PROG_CC_C99
+ AC_PROG_RANLIB
+ AC_PROG_YACC
++AM_PROG_AR
+ AM_PROG_LEX
+ AS_IF([test "x$LEX" == x],
+ [AC_MSG_ERROR([A Lex/Flex program is required in order to compile wcalc.])],
diff --git a/sci-calculators/wcalc/wcalc-2.5.ebuild b/sci-calculators/wcalc/wcalc-2.5.ebuild
index 9b9a8d8b67a6..f7a5e03f83ee 100644
--- a/sci-calculators/wcalc/wcalc-2.5.ebuild
+++ b/sci-calculators/wcalc/wcalc-2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils
+inherit autotools desktop
DESCRIPTION="A flexible command-line scientific calculator"
HOMEPAGE="http://w-calc.sourceforge.net/"
@@ -20,6 +20,13 @@ RDEPEND="
readline? ( sys-libs/readline:0= )"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-AR.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf $(use_with readline)
}