summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:49:43 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:50 +0100
commite61ccb6f836b6b414a2a3df25747bfd63d4371bf (patch)
treea700495b1e6a973e3f495eaed3ff7c2051f05202
parentdev-python/itypes: Migrate to PEP517 build (diff)
downloadgentoo-e61ccb6f836b6b414a2a3df25747bfd63d4371bf.tar.gz
gentoo-e61ccb6f836b6b414a2a3df25747bfd63d4371bf.tar.bz2
gentoo-e61ccb6f836b6b414a2a3df25747bfd63d4371bf.zip
dev-python/coreapi: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/coreapi/coreapi-2.3.3-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/coreapi/coreapi-2.3.3-r2.ebuild b/dev-python/coreapi/coreapi-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..02f186b758d1
--- /dev/null
+++ b/dev-python/coreapi/coreapi-2.3.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-client-${PV}
+DESCRIPTION="Python client library for Core API"
+HOMEPAGE="https://github.com/core-api/python-client"
+SRC_URI="
+ https://github.com/core-api/python-client/archive/${PV}.tar.gz
+ -> core-api-${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/itypes[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest