summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-03 15:00:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-05 19:01:53 +0100
commite657333bdb86750a704693e1dcbe7431d95c7e70 (patch)
treea29bf91dc376355324271ab8439f3c529cec5adc
parentkde-apps/dolphin-plugins-git: 22.12.1 version bump (diff)
downloadgentoo-e657333bdb86750a704693e1dcbe7431d95c7e70.tar.gz
gentoo-e657333bdb86750a704693e1dcbe7431d95c7e70.tar.bz2
gentoo-e657333bdb86750a704693e1dcbe7431d95c7e70.zip
kde-apps/dolphin-plugins-mercurial: 22.12.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-mercurial/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-22.12.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-mercurial/Manifest b/kde-apps/dolphin-plugins-mercurial/Manifest
index 59678f83ca61..5adfe8d651f0 100644
--- a/kde-apps/dolphin-plugins-mercurial/Manifest
+++ b/kde-apps/dolphin-plugins-mercurial/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.08.3.tar.xz 260088 BLAKE2B 2927d42a603776cc3b600606ff2f27a77c8bbbe6b089d3e691571c7594d0e4d53023064afbf07e02f546073823a873fd45f200ea13b9e2765b61046602d8239b SHA512 2201858d9d349c28cced78dcfd9a31c3fde05b3ab107a28615af4cc5c32d4315074881f78dfb255638a13269de16ab68b7c53b68d013cf46ded091f8b059173e
DIST dolphin-plugins-22.12.0.tar.xz 268876 BLAKE2B 8a21afe22227fdea29a63b09a6adcb5e6f263f9a0b11adad7466c72c3c145c4ce906b4acf77ced9c6a51d68d19f991e0c2933029d5848e10afa1eb7a3cd8da3a SHA512 be257382b493c2f318cfba7c594a1ef89c358ba5ccb3ff7478313040923f319106a1f94fcf9699695d3d17b59031bcdc88352fc6c58f779475b41a5080dc2126
+DIST dolphin-plugins-22.12.1.tar.xz 268820 BLAKE2B e2468bb550d779d89808a59839f191fc5dd75a0146dfd3a2ba6dac823df8ea62b6425d5ca074b189f5d06e5f461b2edeb49423718e4da767e11edac3e6c35154 SHA512 7f3a3795050371b38e77b726eb74b2c0b0bc777056402a36c3f85e3e58103f2a56d73fa599a45572516aaa2e173f0fc3adf4ced6a5d8aabd4d07939c05deb62c
diff --git a/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-22.12.1.ebuild b/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-22.12.1.ebuild
new file mode 100644
index 000000000000..354de22a6270
--- /dev/null
+++ b/kde-apps/dolphin-plugins-mercurial/dolphin-plugins-mercurial-22.12.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="hg"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.101.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Mercurial integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/mercurial
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}