summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-08-07 13:49:04 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-08-07 13:51:55 +0300
commite70e26dba37b28340c631ad00489863ddd412cc6 (patch)
tree1b8091ae5b8bec08823897f3c19940a52d104359
parentapp-arch/makeself: EAPI 6 bump (diff)
downloadgentoo-e70e26db.tar.gz
gentoo-e70e26db.tar.bz2
gentoo-e70e26db.zip
sys-apps/yum: version bump
Set Python shebang properly for /usr/bin/yum Add missing 'python' USE-flag to app-arch/rpm dependency Drop old vulnerable versions Gentoo-Bug: 499328 Gentoo-Bug: 563850 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--sys-apps/yum/Manifest2
-rw-r--r--sys-apps/yum/yum-3.4.3_p20130218.ebuild43
-rw-r--r--sys-apps/yum/yum-3.4.3_p20170619.ebuild (renamed from sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild)22
3 files changed, 12 insertions, 55 deletions
diff --git a/sys-apps/yum/Manifest b/sys-apps/yum/Manifest
index b70b9c24bc89..442a88fe63a2 100644
--- a/sys-apps/yum/Manifest
+++ b/sys-apps/yum/Manifest
@@ -1 +1 @@
-DIST yum-3.4.3_p20130218.tar.gz 1389537 SHA256 efc2daeca86ddc893eb0489342686eb4a2b2cbbd1a75fd42fd27624225494ce7 SHA512 b450c6133443f674bd60f59633d5669d9f88e60930657891f428ce8f1bdcf7124a86ed756a6a5912b9237788854331022119a6bfb1d5cac8d8fdc3de11b1020e WHIRLPOOL 18bcff3b9f2e991f255ac5bc07937e67c20df46ec88fff1481e5f64fc36f97e5d741cfb378c4731a1721f1d0a9beb6f9d37a5f91b59055cfcb21ac06fce819b6
+DIST yum-3.4.3_p20170619.tar.gz 1525362 SHA256 c97cb357ca7f1180130007e3f8c733de7868d144b6bdb70356370ed110832d41 SHA512 4dddc3e30be8e86162b7786d7cf4e4e6f00e67c03bc3b16f347df1e54c3c67e5eaa01456e19952452a4eeaa4bc40c9a82a042d43772ad304c87c44bdc36e7ea3 WHIRLPOOL bdca57657b7d2405e04607f622d74aa94d5966bea15e1249ed47a82f3239949e2d380d6415a3e5ee089996762de412c2f60bf0f86f25dac91916322b26725847
diff --git a/sys-apps/yum/yum-3.4.3_p20130218.ebuild b/sys-apps/yum/yum-3.4.3_p20130218.ebuild
deleted file mode 100644
index 25cb7e9308cd..000000000000
--- a/sys-apps/yum/yum-3.4.3_p20130218.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-MY_PV="a119004"
-MY_P="${PN}-${MY_PV}"
-
-inherit eutils multilib python-single-r1
-
-DESCRIPTION="automatic updater and package installer/remover for rpm systems"
-HOMEPAGE="http://yum.baseurl.org/"
-SRC_URI="https://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- app-arch/rpm[${PYTHON_USEDEP}]
- dev-python/sqlitecachec[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/urlgrabber[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-util/intltool
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- sed -i -e 's/make/$(MAKE)/' Makefile || die
- sed -i -e "s:lib:$(get_libdir):g" rpmUtils/Makefile yum/Makefile || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- python_optimize "${D%/}$(python_get_sitedir)" "${ED%/}/usr/share/yum-cli"
- rm -r "${ED%/}/etc/rc.d" || die
-}
diff --git a/sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild b/sys-apps/yum/yum-3.4.3_p20170619.ebuild
index 4ef67a210cc4..25ff9b059b59 100644
--- a/sys-apps/yum/yum-3.4.3_p20130218-r1.ebuild
+++ b/sys-apps/yum/yum-3.4.3_p20170619.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
-
-MY_PV="a119004"
-MY_P="${PN}-${MY_PV}"
-
-inherit eutils multilib python-single-r1
+inherit python-single-r1 systemd
DESCRIPTION="automatic updater and package installer/remover for rpm systems"
HOMEPAGE="http://yum.baseurl.org/"
-SRC_URI="https://dev.gentoo.org/~creffett/distfiles/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~ppc ~x86"
+
IUSE="test"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- app-arch/rpm[${PYTHON_USEDEP}]
+ app-arch/rpm[python,${PYTHON_USEDEP}]
dev-python/sqlitecachec[${PYTHON_USEDEP}]
dev-libs/libxml2[python,${PYTHON_USEDEP}]
dev-python/pyliblzma[${PYTHON_USEDEP}]
@@ -32,15 +31,16 @@ DEPEND="${RDEPEND}
dev-util/intltool
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
sed -i -e 's/make/$(MAKE)/' Makefile || die
sed -i -e "s:lib:$(get_libdir):g" rpmUtils/Makefile yum/Makefile || die
+ default
}
src_install() {
- emake DESTDIR="${ED}" install
+ emake INIT=systemd UNITDIR="$(systemd_get_systemunitdir)" DESTDIR="${ED}" install
python_optimize "${D%/}$(python_get_sitedir)" "${ED%/}/usr/share/yum-cli"
rm -r "${ED%/}/etc/rc.d" || die
+ # bug #563850
+ python_fix_shebang "${ED}/usr/bin/yum"
}