summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 06:11:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:11:40 +0200
commite72924e96b937555f261da20a7b2c7b521224c88 (patch)
tree769dba82d9f0aaaf0a19a668bd4fce99a0335ec6
parentdev-python/podcastparser: Enable py3.12 (diff)
downloadgentoo-e72924e96b937555f261da20a7b2c7b521224c88.tar.gz
gentoo-e72924e96b937555f261da20a7b2c7b521224c88.tar.bz2
gentoo-e72924e96b937555f261da20a7b2c7b521224c88.zip
dev-python/pockets: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pockets/pockets-0.9.1-r3.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/pockets/pockets-0.9.1-r3.ebuild b/dev-python/pockets/pockets-0.9.1-r3.ebuild
index f39fc6248076..39add067ef57 100644
--- a/dev-python/pockets/pockets-0.9.1-r3.ebuild
+++ b/dev-python/pockets/pockets-0.9.1-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -12,7 +12,11 @@ inherit distutils-r1
COMMIT="777724c8eabaf76f6d0c5e4837c982d110509b2e"
DESCRIPTION="Collection of helpful Python tools"
-HOMEPAGE="https://pockets.readthedocs.io/ https://pypi.org/project/pockets/"
+HOMEPAGE="
+ https://pockets.readthedocs.io/
+ https://github.com/RobRuana/pockets/
+ https://pypi.org/project/pockets/
+"
SRC_URI="
https://github.com/RobRuana/pockets/archive/${COMMIT}.tar.gz
-> ${P}.gh.tar.gz
@@ -23,9 +27,13 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~x86 ~amd64-linux ~x86-linux"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
BDEPEND="
- test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest