summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:52:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:53:04 -0500
commite73712db9ce780afe78b37319a27496be15e8648 (patch)
tree55727287dcadd45195e4f00c4a3f5ddb316de305
parentapp-crypt/certbot-nginx: 0.27.1 bump (diff)
downloadgentoo-e73712db9ce780afe78b37319a27496be15e8648.tar.gz
gentoo-e73712db9ce780afe78b37319a27496be15e8648.tar.bz2
gentoo-e73712db9ce780afe78b37319a27496be15e8648.zip
app-admin/ansible: 2.6.4 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.6.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index c84ddb4e28a8..82dffd6a8d07 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -4,3 +4,4 @@ DIST ansible-2.5.8.tar.gz 10169397 BLAKE2B 7cb0abb168af25a3cd7b94880309cf19f018a
DIST ansible-2.6.1.tar.gz 10724749 BLAKE2B af4523ab904660fa3369bdae2839ab4b2f386235be5a004e1f9a9a5f7c555a2e6fe82319abe20ecbf7e74152f8e2ad5060fda2c2af0f5d62fdd9416901c9072c SHA512 1235e12a510317665956bfae9e0d03814083a24ba6e5c98072437e50b4a596437a173b32d9d5af37b4b9e168e35045fdb65e65276fdc830f473ab1f42dcba2d2
DIST ansible-2.6.2.tar.gz 10738149 BLAKE2B ac46fe99da9aba55702c578c6d177b7cb1bcd17fb73f08f160afbbcb6a868de721202492e8198e8cb8c68a1ce771572ce0bb598cd310f2ce35d08b0aeeee3f8d SHA512 2283d69be267474e839af44e0e7a14a5532cadef7d65baa2af4045cb93d88b76890b735a78cce348916c04f5dc3c2ed78deb22bb8d94d0c0c0306180d79b1a9b
DIST ansible-2.6.3.tar.gz 10748570 BLAKE2B ff27e46771ab5c574202a195bdddb2affc256ba67de98627ef07d3899a1b6bbdb742a71deff63ad6a22aa53298eb22a22a44a885f53098e2404823565fbc513c SHA512 f34052379b892d5dff5e170e4237d4595ecf9d951226cc928fc092e253f5fa9f492a6e953ff09ed63b19ddb0f2b8df66ac738c2f48923e6d5b1dcc96fc2799c9
+DIST ansible-2.6.4.tar.gz 10751810 BLAKE2B 16a01b76387b6fb0c6554861fd02a57858cf2623ea89e55c0940589b69a6589d4db00bdf87f1e51ab64e638c187657f66ebb5af33a6fa008b7f1dba1e853b3f3 SHA512 b3dc3469dd7e34e3b39b3382df65c3684a44be0515f68861997a4d0e5fce44d64000bc0da0b38fd3d27b45aa1ec3973da581482e0de54c5cc41eb761b230b116
diff --git a/app-admin/ansible/ansible-2.6.4.ebuild b/app-admin/ansible/ansible-2.6.4.ebuild
new file mode 100644
index 000000000000..6ca07021a91a
--- /dev/null
+++ b/app-admin/ansible/ansible-2.6.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}