summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-05-24 23:28:19 -0400
committerMike Frysinger <vapier@gentoo.org>2017-05-24 23:28:33 -0400
commite788203f03488a5b46ce4a4dbc68125b6458f1ba (patch)
treeac8eaa40262447df7e4396e623226eaedc7d0a4c
parentnet-misc/openssh: fix some cross-compiling configure tests (diff)
downloadgentoo-e788203f03488a5b46ce4a4dbc68125b6458f1ba.tar.gz
gentoo-e788203f03488a5b46ce4a4dbc68125b6458f1ba.tar.bz2
gentoo-e788203f03488a5b46ce4a4dbc68125b6458f1ba.zip
net-misc/chrome-remote-desktop: version bump to 57.0.2987.37
-rw-r--r--net-misc/chrome-remote-desktop/Manifest1
-rw-r--r--net-misc/chrome-remote-desktop/chrome-remote-desktop-57.0.2987.37.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-misc/chrome-remote-desktop/Manifest b/net-misc/chrome-remote-desktop/Manifest
index 4bba75791651..40c332d91e0b 100644
--- a/net-misc/chrome-remote-desktop/Manifest
+++ b/net-misc/chrome-remote-desktop/Manifest
@@ -2,3 +2,4 @@ DIST chrome-remote-desktop_49.0.2623.40_amd64.deb 20315570 SHA256 2f3cb883e1ff24
DIST chrome-remote-desktop_49.0.2623.40_i386.deb 20941574 SHA256 00e480a90b3ed3545ea762d7501b323f2471eb06b11f87882c046598b8f38df7 SHA512 00cf6641ee993fb8c295ca99cb57cde42eb3dd6cc34ae4684f858279615695d5b1a257081e8988293f94e887986492e112bc0276f572cd592d9879dec88eace8 WHIRLPOOL effd2650ee7d5b97f87ede0ac79bc1818ddc06e3eb742a080b12a4ef67283f5ba20495d5a5b4f5a5923d2a9a574a711513344b08abac3938ad142f27af48ed88
DIST chrome-remote-desktop_55.0.2883.50_amd64.deb 21636452 SHA256 972b48e05ee80c38b30a362147b051b560051e80e17874eaa32d9bfea53066ae SHA512 3e140407d6e34caed18f3280d2136ea924ba7c9fc0159cde4981927be9c0bd090c58581ed01b3a99b8a796211500ff1588a847d5d3273ec814d9fb10285a97f8 WHIRLPOOL abca4bba11ea4f8044247a102eec2b761b403b3fccc3c1f4cd3694265f629c146b21122034b2f1adb986325a22f48db90f1c43d2bfdf647122e4054e3864c190
DIST chrome-remote-desktop_56.0.2924.51_amd64.deb 13879608 SHA256 7bdb11e9fe929ca263bb0a9b813f6cd7f6762c3e33166735afa3b6d16343b896 SHA512 0578f430d93270b398c7341515e10e25ffe4c8827b3a8dc01b789fc530eb0919cd560bfa8377d5e1f0c74c53db7ba2f60354c57e2c435dcb411d9168610a3b7f WHIRLPOOL dc9407e4416b38b43cfdd99948072886c6c8dae92b273413995a701cab0e15351474cec03d43717a4da312583a14da78e07a8bd54dee3f3f76542ee654846b93
+DIST chrome-remote-desktop_57.0.2987.37_amd64.deb 15677362 SHA256 65e510b6b0ae203f421ba7404446c679620e4448f10ea469684286931840200d SHA512 df470d9f69545dd2793b5d97674bb8724f5ad3dfad05b4d5572b01a21443d79e6776fb72ca14044d7ee00660b7d040023c9716e2568551e2862bdfd3cff99d88 WHIRLPOOL c7d469d30ac0a8aea7e655795ed3bf421a7e214594c3013272c56a056f350199450ba6aae95bd666b3ca04a8e1c1e7be120f0c06fcdc4708f65c4ed863cf084a
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-57.0.2987.37.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-57.0.2987.37.ebuild
new file mode 100644
index 000000000000..47641db6d60e
--- /dev/null
+++ b/net-misc/chrome-remote-desktop/chrome-remote-desktop-57.0.2987.37.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
+# Fetch the Release file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
+# Which gives you the Packages file:
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
+# https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
+# And finally gives you the file name:
+# pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
+#
+# Use curl to find the answer:
+# curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages | grep ^Filename
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PLOCALES=(
+ am ar bg bn ca cs da de el en-GB en es-419 es et fa fil fi fr gu he hi hr
+ hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw
+ ta te th tr uk vi zh-CN zh-TW
+)
+
+inherit unpacker eutils python-single-r1 l10n
+
+DESCRIPTION="access remote computers via Chrome!"
+PLUGIN_URL="https://chrome.google.com/remotedesktop"
+HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
+BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
+SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="${PLOCALES[*]/#/l10n_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# All the libs this package links against.
+RDEPEND="app-admin/sudo
+ ${PYTHON_DEPS}
+ >=dev-libs/expat-2
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/psutil
+ gnome-base/gconf:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/pam
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/pango"
+# Settings we just need at runtime.
+RDEPEND+="
+ x11-base/xorg-server[xvfb]"
+DEPEND=""
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+ python_fix_shebang opt/google/chrome-remote-desktop/chrome-remote-desktop
+}
+
+src_install() {
+ pushd opt/google/chrome-remote-desktop/remoting_locales >/dev/null || die
+ rm -f fake-bidi.pak
+ local l
+ for l in "${PLOCALES[@]}" ; do
+ use "l10n_${l}" || rm -f "${l}.pak"
+ done
+ popd >/dev/null
+
+ insinto /etc
+ doins -r etc/opt
+
+ insinto /opt
+ doins -r opt/google
+ chmod a+rx "${ED}"/opt/google/${PN}/* || die
+
+ dodir /etc/pam.d
+ dosym system-remote-login /etc/pam.d/${PN}
+
+ dodoc usr/share/doc/${PN}/changelog*
+
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Two ways to launch the server:"
+ elog "(1) access an existing desktop"
+ elog " (a) install the Chrome plugin on the server & client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) on the server, run the Chrome plugin & enable remote access"
+ elog " (c) on the client, connect to the server"
+ elog "(2) headless system"
+ elog " (a) install the Chrome plugin on the client:"
+ elog " ${PLUGIN_URL}"
+ elog " (b) run ${EPREFIX}opt/google/chrome-remote-desktop/start-host --help to get the auth URL"
+ elog " (c) when it redirects you to a blank page, look at the URL for a code=XXX field"
+ elog " (d) run start-host again, and past the code when asked for an authorization code"
+ elog " (e) on the client, connect to the server"
+ elog
+ elog "Configuration settings you might want to be aware of:"
+ elog " ~/.${PN}-session - shell script to start your session"
+ elog " /etc/init.d/${PN} - script to auto-restart server"
+ fi
+}