summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-22 14:51:36 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-22 14:51:36 +0100
commite79083b37ffeaa5812d4afe37eeb5c69ec4d449a (patch)
treeedefdbdacb51b6edcaa8cc40f2b6926220ab144f
parentdev-ml/camldbm: do not call ranlib directly (diff)
downloadgentoo-e79083b37ffeaa5812d4afe37eeb5c69ec4d449a.tar.gz
gentoo-e79083b37ffeaa5812d4afe37eeb5c69ec4d449a.tar.bz2
gentoo-e79083b37ffeaa5812d4afe37eeb5c69ec4d449a.zip
dev-ml/camlidl: do not call ar directly
Closes: https://bugs.gentoo.org/723136 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
index 06fafb20cc46..2dfb9b3cf8db 100644
--- a/dev-ml/camlidl/camlidl-1.05-r1.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,14 @@ PATCHES=(
"${FILESDIR}/nowarn.patch"
)
+src_prepare() {
+ sed -i \
+ -e "s|ar rc|$(tc-getAR) rc|g" \
+ runtime/Makefile.unix \
+ || die
+ default
+}
+
src_compile() {
# Use the UNIX makefile
libdir=$(ocamlc -where || die)
@@ -42,7 +50,7 @@ src_test() {
src_install() {
libdir=$(ocamlc -where || die)
- dodir ${libdir#${EPREFIX}}/caml
+ dodir "${libdir#${EPREFIX}}"/caml
dodir /usr/bin
# Install