summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-17 13:51:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-17 16:10:03 +0200
commite79ba40b728834f97b0eea4b596601477ca3210f (patch)
tree6095621f0246b3dd4fe41b8e6f77cc308a27a4b2
parentdev-python/numpy: Fix installing generated files (diff)
downloadgentoo-e79ba40b.tar.gz
gentoo-e79ba40b.tar.bz2
gentoo-e79ba40b.zip
dev-python/numpy-python2: Fix installing generated files
Closes: https://bugs.gentoo.org/717502 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/numpy-python2/numpy-python2-1.16.5-r1.ebuild (renamed from dev-python/numpy-python2/numpy-python2-1.16.5.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild b/dev-python/numpy-python2/numpy-python2-1.16.5-r1.ebuild
index b6c8b4fa6cf0..1eb5f203c4fe 100644
--- a/dev-python/numpy-python2/numpy-python2-1.16.5.ebuild
+++ b/dev-python/numpy-python2/numpy-python2-1.16.5-r1.ebuild
@@ -151,6 +151,8 @@ sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
}
python_install() {
+ # https://github.com/numpy/numpy/issues/16005
+ local mydistutilsargs=( build_src )
distutils-r1_python_install ${NUMPY_FCONFIG}
python_optimize
}