summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-04 05:20:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-04 05:39:52 +0100
commite812d36543ab25526617d60ec2607debf28c6d65 (patch)
tree88e6326c09b96466ac257d1e82a19a5af2558acf
parentdev-python/fakeredis: Bump to 2.7.0 (diff)
downloadgentoo-e812d36543ab25526617d60ec2607debf28c6d65.tar.gz
gentoo-e812d36543ab25526617d60ec2607debf28c6d65.tar.bz2
gentoo-e812d36543ab25526617d60ec2607debf28c6d65.zip
dev-python/hypothesis: Bump to 6.66.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.66.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 9a1a034b57e2..5ddde784332b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-6.65.0.gh.tar.gz 9347619 BLAKE2B 5e67e4659d883209aefe3a459620a2d
DIST hypothesis-6.65.1.gh.tar.gz 9347804 BLAKE2B 555b8eb742b35cffbc0985394b7b830fbff0c601c031b270ffb50c8e1e8437b99c4f827b92cfc74f5239aac43b34e70520b3674129c70338ad010b289552b14b SHA512 faa1330477a5932b47af5c0b70742a81455aba85f5ba19e355a1678a23e62612a8972e510f3bd0f133491fdd5c2f293a4ea2f75e181dedaa3304d789e3bc90cc
DIST hypothesis-6.65.2.gh.tar.gz 9349189 BLAKE2B 4a36cde376a56c9eee7645c76606777e8c40144f0495a1a6f2d2d840262be26f52e077f932e90790214decfbc3fbb9b3f64add1830e451bb8e56b8c9c5ba5f34 SHA512 0955e95d9d97f44170dfc937c3ea6b43f6c4ac74dbb48e16a4998e735310f72448083382f6628b4bb9620ac0d21d6c749a5464c6a7caee24cdb7af8cd0c01dcb
DIST hypothesis-6.66.0.gh.tar.gz 9349578 BLAKE2B 3dcdd9bcca00849d68a4bf1368784099bf69e25634b7d1dae13b40be2ac67959151c1b9cdf233349197de1a0f100d57baebbeb9a691ce56ec2d81d21c9f48989 SHA512 a73648ba0b4e3a0621e843ad3ea32f3f692374b82881b096c86a9609f4f7d1a277dd5265a4104863c648c6d5ee4dbccdb1d80ffe62bcc303f837cea26f7d40f2
+DIST hypothesis-6.66.1.gh.tar.gz 9349822 BLAKE2B 728b6e1cb2a28a07cae066bb2e2f8099f21f9a27dbbcc27db1c4f97f6541f60464d90344630df75eb5cea9a65e865a296dbd8b5e20bcbbc17840c92d8f269ac7 SHA512 58ddb6c2bb77064d25ace1740bc5a9ba4d4b6c311da065aa065854c19d4920ec9d70b83935e1b9d057eb10c96c4fdfb445d17c6f321578cbde449df3c5edf704
diff --git a/dev-python/hypothesis/hypothesis-6.66.1.ebuild b/dev-python/hypothesis/hypothesis-6.66.1.ebuild
new file mode 100644
index 000000000000..c793a8a143d2
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.66.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}