summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-06 13:25:10 +0100
committerSam James <sam@gentoo.org>2021-08-06 13:25:16 +0100
commite84d205ecddf1ea10c2b6865fa6153311d8bdc5e (patch)
tree2d2ccaab9d08e7f0ef00cbcde694c5042d5c2872
parentapp-crypt/qca: Stabilize 2.3.3 arm64, #800175 (diff)
downloadgentoo-e84d205ecddf1ea10c2b6865fa6153311d8bdc5e.tar.gz
gentoo-e84d205ecddf1ea10c2b6865fa6153311d8bdc5e.tar.bz2
gentoo-e84d205ecddf1ea10c2b6865fa6153311d8bdc5e.zip
dev-python/pysol_cards: add 0.10.2
Only with the setuptools hyphen fix. Closes: https://bugs.gentoo.org/796416 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pysol_cards/Manifest1
-rw-r--r--dev-python/pysol_cards/pysol_cards-0.10.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pysol_cards/Manifest b/dev-python/pysol_cards/Manifest
index 3c0e3f8a6669..f129b3ece6d4 100644
--- a/dev-python/pysol_cards/Manifest
+++ b/dev-python/pysol_cards/Manifest
@@ -1 +1,2 @@
DIST pysol_cards-0.10.1.tar.gz 20670 BLAKE2B 1183502ec0e7c070686ed5fc2972091a5bf91d55e31170690124e949bd592401daaae44cf25e3ac9b213230e27fbc90ea9e58450d75caa09b9467f0d2ba513cc SHA512 40ef02fe919f961688039667b9073913acb452d163eef1a4ef71648788676c678bf615a26b1f4d562ba072167eb3629c4cc463678edff89bfdc62b0878db062c
+DIST pysol_cards-0.10.2.tar.gz 20776 BLAKE2B b9f3f20e983453196a7db78ac81c17eb35f157e6419a9dd25e6286ab82763bf2a1601177e41abfe0f49367189a4a78ac66e4f77151c52acae006e3198ff8c524 SHA512 df8848c63ad12496c4346fc51fbac803b7a27c274147d458c78f937b70c804cddeeece8c6a980ef2a422bb17771ee1825c9824843e7d1cbc47e3678e506a30c5
diff --git a/dev-python/pysol_cards/pysol_cards-0.10.2.ebuild b/dev-python/pysol_cards/pysol_cards-0.10.2.ebuild
new file mode 100644
index 000000000000..7e42f93af853
--- /dev/null
+++ b/dev-python/pysol_cards/pysol_cards-0.10.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Deal PySol FreeCell cards"
+HOMEPAGE="https://pypi.org/project/pysol-cards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/oslotest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest