summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-18 23:17:47 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-18 23:17:47 +0000
commite8986dda6a53603f0902258e1c0873123c164da0 (patch)
tree8178889957b0206a3acc9770004983e6b011b694
parentdev-libs/wayland: Version bump (diff)
downloadgentoo-e8986dda6a53603f0902258e1c0873123c164da0.tar.gz
gentoo-e8986dda6a53603f0902258e1c0873123c164da0.tar.bz2
gentoo-e8986dda6a53603f0902258e1c0873123c164da0.zip
dev-python/aplpy: version bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/aplpy/Manifest1
-rw-r--r--dev-python/aplpy/aplpy-1.0.ebuild53
-rw-r--r--dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch14
-rw-r--r--dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch121
4 files changed, 189 insertions, 0 deletions
diff --git a/dev-python/aplpy/Manifest b/dev-python/aplpy/Manifest
index f6a8ac76b340..75d52df94ba1 100644
--- a/dev-python/aplpy/Manifest
+++ b/dev-python/aplpy/Manifest
@@ -1 +1,2 @@
DIST APLpy-0.9.14.tar.gz 1095547 SHA256 0313a91523b6a32a40e5b97da55243d5e59722cd8fa2e6642915edd26d464d69 SHA512 9cf12aa30d3c4540c2cc33907be3a12e78247a8880720e4de7e513842ef437f616b2c63a345a63e7a7081676aff56032840dc1528ed10438f7729cf2acb9da9f WHIRLPOOL 55c25aa11065b741e89b1538d96e57974bcb6b80f5708e5ee5f975742f7e04cbfe6df3da7b030c67a54bbcc929eaec46e2d2e34551d8f9e7365e2f2c4d5b3a0d
+DIST APLpy-1.0.tar.gz 1169280 SHA256 09a8a24b46b93a1eacdbc0e6fd480fa38e4dd890a24963136d76185924602ff0 SHA512 658b626c2a94c73cc8ba45fde86409659555ed3ec065d07313f08b67c0bcdc596c8dc94562c924de2f3f32d6884051e6756e22384d9594c4538578b482fa7590 WHIRLPOOL 0c884cecbbc9a7cd4ca4ba48cee4e03f039fa2edf4aa5aa4ac945b58c889084acb762f9cff2014911b383b0b14ebd2e51d2ce28b01b87eb0053ba06c3cc6c5c3
diff --git a/dev-python/aplpy/aplpy-1.0.ebuild b/dev-python/aplpy/aplpy-1.0.ebuild
new file mode 100644
index 000000000000..5d0cd8a3f517
--- /dev/null
+++ b/dev-python/aplpy/aplpy-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+MYPN=APLpy
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Astronomical Plotting Library in Python"
+HOMEPAGE="https://aplpy.github.com/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pyavm[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0-mark-known-failures.patch"
+ "${FILESDIR}/${PN}-1.0-fix-dependencies.patch"
+)
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ virtx "${EPYTHON}" -c "import aplpy, sys;r = aplpy.test();sys.exit(r)" \
+ || die "tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch b/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch
new file mode 100644
index 000000000000..b5708c8971bc
--- /dev/null
+++ b/dev-python/aplpy/files/aplpy-1.0-fix-dependencies.patch
@@ -0,0 +1,14 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Change requires to install_requires
+--- a/setup.py
++++ b/setup.py
+@@ -94,8 +94,7 @@
+ version=VERSION,
+ description=DESCRIPTION,
+ scripts=scripts,
+- requires=['astropy', 'numpy', 'matplotlib'],
+- install_requires=['astropy'],
++ install_requires=['astropy', 'numpy', 'matplotlib'],
+ provides=[PACKAGENAME],
+ author=AUTHOR,
+ author_email=AUTHOR_EMAIL,
diff --git a/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch b/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch
new file mode 100644
index 000000000000..cf1aa92190d4
--- /dev/null
+++ b/dev-python/aplpy/files/aplpy-1.0-mark-known-failures.patch
@@ -0,0 +1,121 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Mark tests that are known to fail with matplotlib-1.5
+--- a/aplpy/tests/test_images.py
++++ b/aplpy/tests/test_images.py
+@@ -61,6 +61,8 @@
+
+ class TestBasic(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for showing grayscale
+ def test_basic_image(self, generate):
+ f = FITSFigure(self.filename_2)
+@@ -68,6 +70,8 @@
+ self.generate_or_test(generate, f, 'basic_image.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_ticks_labels_options(self, generate):
+ f = FITSFigure(self.filename_2)
+ f.ticks.set_color('black')
+@@ -84,6 +88,8 @@
+ self.generate_or_test(generate, f, 'tick_labels_options.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for showing colorscale
+ def test_show_colorbar_scalebar_beam(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -96,6 +102,8 @@
+ self.generate_or_test(generate, f, 'colorbar_scalebar_beam.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for overlaying shapes
+ def test_overlay_shapes(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -112,6 +120,8 @@
+ self.generate_or_test(generate, f, 'overlay_shapes.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test for grid
+ def test_grid(self, generate):
+ f = FITSFigure(self.filename_1)
+@@ -125,6 +135,8 @@
+ self.generate_or_test(generate, f, 'grid.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test recenter
+ def test_recenter(self, generate):
+ f = FITSFigure(self.filename_2)
+@@ -135,6 +147,8 @@
+ self.generate_or_test(generate, f, 'recenter.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test overlaying contours
+ def test_contours(self, generate):
+ data = np.arange(256).reshape((16, 16))
+@@ -144,6 +158,8 @@
+ self.generate_or_test(generate, f, 'contours.png')
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ # Test cube slice
+ def test_cube_slice(self, generate):
+ f = FITSFigure(self.filename_3, dimensions=[2, 0], slices=[10])
+--- a/aplpy/tests/test_rgb.py
++++ b/aplpy/tests/test_rgb.py
+@@ -6,6 +6,7 @@
+
+ import numpy as np
+ from astropy.io import fits
++from astropy.tests.helper import pytest
+
+ from .. import FITSFigure
+ from ..rgb import make_rgb_image
+@@ -17,6 +18,8 @@
+
+ class TestRGB(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_rgb(self, generate, tmpdir):
+
+ # Regression test to check that RGB recenter works properly
+--- a/aplpy/tests/test_vectors.py
++++ b/aplpy/tests/test_vectors.py
+@@ -1,4 +1,5 @@
+ import numpy as np
++from astropy.tests.helper import pytest
+
+ from ..core import FITSFigure
+
+@@ -15,6 +16,8 @@
+
+ class TestVectors(BaseImageTests):
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_default(self, generate):
+ f = FITSFigure(IMAGE, figsize=(4,4))
+ f.show_grayscale()
+@@ -22,6 +25,8 @@
+ self.generate_or_test(generate, f, 'vectors_default.png', tolerance=2.5)
+ f.close()
+
++# see https://github.com/aplpy/aplpy/issues/278
++ @pytest.mark.xfail()
+ def test_step_scale(self, generate):
+ f = FITSFigure(IMAGE, figsize=(4,4))
+ f.show_grayscale()