summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-13 08:00:32 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-13 08:00:32 +0100
commite8acc4a0b65194f3b777da9f13f9ee7b099b44e1 (patch)
tree12478835708019a3a0e23b009687887f0f397770
parentdev-ruby/rails: add 6.1.5 (diff)
downloadgentoo-e8acc4a0b65194f3b777da9f13f9ee7b099b44e1.tar.gz
gentoo-e8acc4a0b65194f3b777da9f13f9ee7b099b44e1.tar.bz2
gentoo-e8acc4a0b65194f3b777da9f13f9ee7b099b44e1.zip
dev-ruby/activesupport: add 7.0.2.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.0.2.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 46480e2a2222..b4927870c08e 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -10,3 +10,4 @@ DIST rails-6.1.4.4.tgz 11006695 BLAKE2B af5afbd1adafa259f3d58d31e8e616be5e83e73d
DIST rails-6.1.4.6.tgz 11006958 BLAKE2B e365570a5d4b0e46803ec0c13639e43f4258c068362a706c99cce8b308463ef4612ff0ceeaa98877354dc40655d8a5d1302e1cb7b3e7b265e8fa466ce7ddc124 SHA512 89f1bbfa8bb91db26203375b979eabdfee4b085c85787557fae2d55182fa1c048cd00ff28ef20dd95f062dcaeb1f1d99be6fd081821268c8263295866ff2983e
DIST rails-6.1.5.tgz 11017020 BLAKE2B 5e1a167550998f8149ac770397f4e39a979f48365494f97d4b387559070e4e9264ddc93bf20e5c19537b4683a793a2c316bcb3f829cc05f0155b31a609da6756 SHA512 a90fe7781ddbb6a035ea7dcb950e2ab03a7297502891d4a88dfe7c3ef90b78d8009ea62a35272d3500e8819466042b883193ebb030683fc2cf7e5dc0e720edb1
DIST rails-7.0.2.2.tgz 11034626 BLAKE2B 388a27b5434f1ae062cb7c3a68881a885dd659dbd9e86c4d36e0cb29c493f127fb9cbdf0f9ce7dea5a715ddbcd7a3bff5e2de3adb2e278c8bf63c2473d1e4b6d SHA512 e7863f1e072d266b8df1abb8abf6b141bad74ef77fe5dbcd66e7603e2ebf386520e4fd8f337edb5f5a6bd5607fbaa146823cbe6980fd7864e3934a7c9d382e3d
+DIST rails-7.0.2.3.tgz 11037677 BLAKE2B b4d0ac3d2c56d262beca4f5ba1659a67526c01321dc00ef8392a11c6fbc7614e3c02cf02ffcbb5ed1911005c1be0c0741e225f45c5946fc9102629c5ba5d32ab SHA512 4dcbe65ce1bad803dd04be61918f1ca893529705a8336a0c09b0193eb453319fc42ed0e2dca6ff5cb56f0c2bc5ab03c9d9f479101904ad1a746980cd887798d4
diff --git a/dev-ruby/activesupport/activesupport-7.0.2.3.ebuild b/dev-ruby/activesupport/activesupport-7.0.2.3.ebuild
new file mode 100644
index 000000000000..e921c0b3b547
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.0.2.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\|view\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}