summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-03-10 21:30:19 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-10 21:32:44 -0500
commite8f3bce6ba5d28067b73ec8cbb92477504bef3a0 (patch)
tree647239c6222e8708435b5a366b250951ee64a19d
parentdev-python/cherrypy: 18.1.0-r1 revbump for dependencies (diff)
downloadgentoo-e8f3bce6ba5d28067b73ec8cbb92477504bef3a0.tar.gz
gentoo-e8f3bce6ba5d28067b73ec8cbb92477504bef3a0.tar.bz2
gentoo-e8f3bce6ba5d28067b73ec8cbb92477504bef3a0.zip
dev-python/cherrypy: remove broken 18.1.0
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-python/cherrypy/cherrypy-18.1.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/cherrypy/cherrypy-18.1.0.ebuild b/dev-python/cherrypy/cherrypy-18.1.0.ebuild
deleted file mode 100644
index db0bd2c75f89..000000000000
--- a/dev-python/cherrypy/cherrypy-18.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/cheroot-5.9.1[${PYTHON_USEDEP}]
- >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
- sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
- -i cherrypy/test/test_static.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "tests failed under ${EPTYHON}"
-}