summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-22 21:04:27 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-22 21:04:42 +0000
commite93088f01d942229515808ff165d616b5191cc6a (patch)
treec4127b7e6ae90a1a0bb517cf7613b6439c87cb49
parentsys-block/fio: Version bump & bug #572446. (diff)
downloadgentoo-e93088f01d942229515808ff165d616b5191cc6a.tar.gz
gentoo-e93088f01d942229515808ff165d616b5191cc6a.tar.bz2
gentoo-e93088f01d942229515808ff165d616b5191cc6a.zip
dev-vcs/git-annex: fix against QC-2.8.2, bug #572504
QuickCheck-2.8.2 introduced default instances for Data.Map and Data.Set. git-annex happened to provide those as well. Reported-by: bugtrack@web.de Reported-by: Matthias Maier Bug: https://bugs.gentoo.org/572504 Package-Manager: portage-2.2.27
-rw-r--r--dev-vcs/git-annex/files/git-annex-6.20160114-QC-2.8.2.patch16
-rw-r--r--dev-vcs/git-annex/git-annex-5.20151218.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-vcs/git-annex/files/git-annex-6.20160114-QC-2.8.2.patch b/dev-vcs/git-annex/files/git-annex-6.20160114-QC-2.8.2.patch
new file mode 100644
index 000000000000..2f232782de02
--- /dev/null
+++ b/dev-vcs/git-annex/files/git-annex-6.20160114-QC-2.8.2.patch
@@ -0,0 +1,16 @@
+diff --git a/Utility/QuickCheck.hs b/Utility/QuickCheck.hs
+index cd408dd..9f60f23 100644
+--- a/Utility/QuickCheck.hs
++++ b/Utility/QuickCheck.hs
+@@ -9,2 +9,3 @@
+ {-# LANGUAGE TypeSynonymInstances #-}
++{-# LANGUAGE CPP #-}
+
+@@ -23,2 +24,3 @@ import Prelude
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary k, Arbitrary v, Eq k, Ord k) => Arbitrary (M.Map k v) where
+@@ -28,2 +30,3 @@ instance (Arbitrary v, Eq v, Ord v) => Arbitrary (S.Set v) where
+ arbitrary = S.fromList <$> arbitrary
++#endif
+
diff --git a/dev-vcs/git-annex/git-annex-5.20151218.ebuild b/dev-vcs/git-annex/git-annex-5.20151218.ebuild
index 8e5b05250e08..7afd432a5ab5 100644
--- a/dev-vcs/git-annex/git-annex-5.20151218.ebuild
+++ b/dev-vcs/git-annex/git-annex-5.20151218.ebuild
@@ -106,6 +106,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# does not respect staging dir
epatch "${FILESDIR}"/${PN}-5.20150731-no-strange-installs.patch
+ epatch "${FILESDIR}"/${PN}-6.20160114-QC-2.8.2.patch
}
src_configure() {