summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-06-02 19:19:01 +0200
committerFabian Groffen <grobian@gentoo.org>2018-06-02 19:25:35 +0200
commitea089bd588671e6a5c1d05049c63012f46cf6f58 (patch)
treef5f5f8e90316176d1af48af84f16e11dfa7bb50d
parentsys-libs/libuuid: drop *-macos keywords, this breaks the system headers (diff)
downloadgentoo-ea089bd588671e6a5c1d05049c63012f46cf6f58.tar.gz
gentoo-ea089bd588671e6a5c1d05049c63012f46cf6f58.tar.bz2
gentoo-ea089bd588671e6a5c1d05049c63012f46cf6f58.zip
sys-libs/native-uuid: new pseudo package for *-macos in Prefix
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-libs/native-uuid/metadata.xml15
-rw-r--r--sys-libs/native-uuid/native-uuid-1.0.ebuild36
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/native-uuid/metadata.xml b/sys-libs/native-uuid/metadata.xml
new file mode 100644
index 000000000000..06454c38b1ef
--- /dev/null
+++ b/sys-libs/native-uuid/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>prefix@gentoo.org</email>
+ <name>Gentoo Prefix</name>
+ </maintainer>
+ <longdescription lang="en">
+ pkgconfig file for host-provided uuid for Prefix systems
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-libs/native-uuid/native-uuid-1.0.ebuild b/sys-libs/native-uuid/native-uuid-1.0.ebuild
new file mode 100644
index 000000000000..2f7e48e9fc4a
--- /dev/null
+++ b/sys-libs/native-uuid/native-uuid-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION=".pc file for uuid"
+HOMEPAGE="https://prefix.gentoo.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="!!sys-libs/libuuid
+ !!sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+}
+
+src_install() {
+ mkdir -p "${ED}"/usr/lib/pkgconfig || die
+ cat > "${ED}"/usr/lib/pkgconfig/uuid.pc <<- EOPC
+ prefix=${EPREFIX}/usr
+ exec_prefix=\${prefix}
+ libdir=${EPREFIX}/usr/lib
+ includedir=\${prefix}/include
+
+ Name: uuid
+ Description: Universally unique id library
+ Version: ${PV}
+ Requires:
+ Cflags:
+ Libs:
+ EOPC
+}